Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   Brakes, Suspension & Body Chassis (http://www.focusfanatics.com/forum/forumdisplay.php?f=159)
-   -   DGR coilover install help!!! (http://www.focusfanatics.com/forum/showthread.php?t=312955)

Bryan23ferra 03-28-2013 09:28 PM

DGR coilover install help!!!
 
I got my DGR's today from a member here. I'm having trouble figuring out how to get the sway bar to work with them.
http://img.tapatalk.com/d/13/03/29/u6ete7ub.jpg
http://img.tapatalk.com/d/13/03/29/guqate9e.jpg

That's what I mean. I can't figure out if maybe you can make the tube of the strut longer or if the sway bar needs to be removed..

Help! Car is in pieces!


Sent from my iPhone using FF Mobile

Bryan23ferra 03-28-2013 09:36 PM

So sitting here eating a sandwich looking at this I realized something... If my dumb self would take off the other sway bar link, the bar would twist... Rookie mistake.


Sent from my iPhone using FF Mobile

felixthecat 03-28-2013 11:32 PM

Great that you figured it out. Sometimes you need to take a break from it, to figure problems out. Let us know how it rides & handles, huh?

Bryan23ferra 03-29-2013 09:42 AM

It rides good, need to get replacement rear shocks but you wouldn't notice. I love how stiff the ride is. There is no more body roll!


Sent from my iPhone using FF Mobile

Bryan23ferra 04-01-2013 12:06 AM

Alright guys.. Now after adjusting them, I'm getting a terrible popping/thud from the front right side. After that happened I put them back to where they were. But lucky me, still getting the sound. It happens when the suspension in moving down on that side. And it's not the sway bar links. The sound is so loud that I don't think it's a control arm bushing either.


Sent from my iPhone using FF Mobile

sailor 04-01-2013 12:47 AM

Sway bar hitting something? Some members have seen them shift & hit as they move, particularly after a suspension change....

Best guess since the new to you assembly didn't make noise when first installed. Otherwise i would have said to remove the right one & check the top mount & the shock itself....

Bryan23ferra 04-01-2013 01:08 AM

I wish I could put a camera in there.


Sent from my iPhone using FF Mobile

Bryan23ferra 04-02-2013 01:08 PM

Figured it out. I reset the preload, now everything is awesome!


Sent from my iPhone using FF Mobile


All times are GMT -5. The time now is 09:01 PM.