Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   SPI Hiccup (http://www.focusfanatics.com/forum/showthread.php?t=310674)

2003focusowner 03-02-2013 09:31 PM

SPI Hiccup
 
My 2003 SPI has always had an occasional hiccup going down the highway. seems to be a little prevelant lately. I have never been able to find the cause of this. I know its been mentioned on here before about others having the same issue. Anyone recall what may have been found to be causing the hiccup?

My SPi has been good to me....just rolled 216,000 miles.

dromeda 03-02-2013 09:42 PM

Mine's done this twice:

1) Every now and then it would shimmy then stop until it always did it and it turned out to be a vacuum leak on the PCV hose (from the intake tube rubbing on it).

2) Spark plugs needed changed. There was no electrode/insulation left and it was arcing inside the plug (or not at all) causing misfires.

Since you said highway, I'm guessing it's a misfire issue. Have you tried pulling any codes? Misfires can happen three ways: no spark, no fuel, no air. When was the last time you pulled the plugs? Any misfire or lean codes?

2003focusowner 03-03-2013 08:26 AM

There have been no codes with this issue. Plugs have 60K on them. I typically change them every 50k. This has done this ever since I bought the car in 2004. Its just starting to do it a little more frequent now.

TheGlassMaker 03-03-2013 08:29 AM

Wouldn't hurt to check and or change the PCV valve and hose. Take the valve out and shake it if it rattles than it still works. If it don't then it needs replaced.

2003focusowner 03-03-2013 08:33 AM

The PCV valve is ok....just checked it.........will have to check the hose......I assume one would be looking for a collapsed hose?

TheGlassMaker 03-03-2013 08:42 AM

That or cracked. They are known to dry out and cause a vacuum leak.

dromeda 03-03-2013 09:29 AM

Could try changing out spark plug wires and coil pack too.

Donnyd21 03-03-2013 06:11 PM

O2 sensor, primary, change it, they are only goo for 80-90k miles before they become slow/very inaccurate.


All times are GMT -5. The time now is 09:39 AM.