Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   car lost all power (http://www.focusfanatics.com/forum/showthread.php?t=309907)

cargo99 02-21-2013 09:13 PM

car lost all power
 
hello, needs some help with 2003 ford focus zx3. My son reversed the car in the driveway today and the engine started to sound awful. (His description made it sound like the timing was off) anyway he took the key out and it would not turn off so he stuck the key back in and released the clutch to stall it out and that turned it off. He tried to turn the car back on and nothing happened. The car has no power when you turn the key. No cluster lights or radio, No clicking, No fuel pump sound. When you turn on the headlights the cluster lights work but the headlights don't work, only the parking lights. We tried to jump it and didn't work, tried to push start it and that didn't work. I checked the ignition starter fuse and it checked good. I m not sure where to start, nothing is making sense to me. The Pat light is blinking slowly even as I try to start car, dont know if that is normal. Battery is showing 12.5 volts. Please help me out so I can sleep peacefully again.

elsolo 02-21-2013 09:41 PM

I would start with fuses, checking both for blown fuses and voltage on the circuits.
You have volts at the battery, now you need to systematically check downstream.

There is also the power hold relay and it's diode.
If the diode gets fried, I think the power hold relay will stay self energized as long as the engine is running.

cargo99 02-23-2013 11:28 PM

fixed
 
Thanks for the quick reply. problem solved, it was the f8 30 amp fuse, I guess somehow I overlooked that fuse the first time I checked them. Thanks again!!


All times are GMT -5. The time now is 10:46 AM.