Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   hey yall, help please (http://www.focusfanatics.com/forum/showthread.php?t=309269)

RedRiderr13 02-14-2013 09:24 PM

hey yall, help please
 
hi guys i started a tread a while back, but i need help again cuz im at a wall.

my car got an engine swap, 2.0 for 2.0, and it is throwing a code for "system lean blank" i figured this was a vacume leak someplace, but i cannot find the leak anywhere, would a bad maf sensor be a cause of this? the main issue is that when im cruising the freeway and light on the pedal, the temp guage rises rapidly, so i cannot drive far. what else could be going wrong that im missing, has anyone here experienced anything like this before? thanks in advance.

sleepyboy 02-14-2013 09:28 PM

Moved to Technical chat

RedRiderr13 02-14-2013 10:29 PM

my bad, its been a while.

Squareleft 02-14-2013 10:47 PM

did you replace your thermostat? Also Maybe the CHT sensor.
P0171 If there is no vacuum leak or the pcv hose isnt collapsed that attaches to the manifold then i would be very positive that the MAF is bad.

RedRiderr13 02-14-2013 11:05 PM

the thermostat was replaced by the people that did the engine swap, but im thinking of trying to put another in and see what the issue was.
this is the code i got and the discription for it:
P0171 - System too Lean (Bank 1)
The Adaptive Fuel Strategy continuously monitors fuel delivery hardware. The test fails when the adaptive fuel tables reach a rich calibrated limit.

BC_ZX3 02-14-2013 11:43 PM

A more detailed description with possible causes:

P0171 - System too Lean (Bank 1)
The Adaptive Fuel Strategy continuously monitors fuel delivery hardware. The test fails when the adaptive fuel tables reach a rich calibrated limit.
Possible causes for lean and rich DTCs:
Fuel system
Excessive fuel pressure.
Leaking/contaminated fuel injectors.
Leaking fuel pressure regulator.
Low fuel pressure or running out of fuel.
Vapor recovery system.
Induction system
Air leaks after the MAF.
Vacuum Leaks.
PCV system.
Improperly seated engine oil dipstick.
EGR system
Leaking gasket.
Stuck EGR valve.
Leaking diaphragm or EVR.
Base Engine
Oil overfill.
Cam timing.
Cylinder compression.
Exhaust leaks before or near the HO2Ss.

A SHRTFT-1,2 PID value between -25% to +35% and a LONGFT-1,2 PID value between -35% to +35% is acceptable. Reading beyond these values indicate a failure.

Squareleft 02-15-2013 12:04 AM

most common causes are the maf and vacuum leaks.

RedRiderr13 02-15-2013 12:28 AM

i guess ill start going thru everything tomoro, starting with maf, i have already searched for vac leaks. thanks again, anyone with any other ideas, please let me know.

RedRiderr13 02-16-2013 07:04 PM

ok, so i changed the MAF sensor, the check engine light is gone now. BUT the car is still doing the whole running hot thing when on the freeway, no what should i look to change out? im thinking the coolent temp sensor,(anyone know where this is??) thanks in advance.

sleepyboy 02-16-2013 09:30 PM

Maybe they put the t-stat in backwards?


All times are GMT -5. The time now is 03:35 AM.


http://www.focusfanatics.com/aboutus/copyright.asp