Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   Sohc help (http://www.focusfanatics.com/forum/showthread.php?t=308548)

Ledgerwood_joey 02-06-2013 03:40 PM

Sohc help
 
My focus drives good and it has a check engine light on for the speed control sensore but it also vibrates the whole car as soon as I hit the gas pedal, it's quiet in nuetral and at really low rpms but it gets louder the faster I drive, and if I downshift and then push the clutch in it dies sometimes, only when I'm speedometers not working and I have no idea what would make it vibrate that bad

crazy_urn 02-06-2013 03:49 PM

Since your CEL says speed control sensor, I would start there. that can cause vibrations and stalls, and other engine issues. Can also cause you to hit governor because the car thinks you are going over 108.

Then, see what problems that clears up and what problems remain. The vibration may be related, it may be separate.

Ledgerwood_joey 02-06-2013 06:30 PM

Ya ill fix that and see cus my governor doesn't work I've gone 125 and it was still accelerating and it never cut out

calebstubstad 02-06-2013 11:28 PM

Quote:

Originally Posted by Ledgerwood_joey (Post 4576024)
Ya ill fix that and see cus my governor doesn't work I've gone 125 and it was still accelerating and it never cut out

with the SPI? not rippin on ya, i have the same engine..
http://www.memecreator.org/static/im...es/1011428.jpg

zetecDon 02-07-2013 03:21 AM

Moved to "General Technical Chat".

crazy_urn 02-07-2013 02:50 PM

Quote:

Originally Posted by Ledgerwood_joey (Post 4576024)
Ya ill fix that and see cus my governor doesn't work I've gone 125 and it was still accelerating and it never cut out

Might be related to the problem with the speed sensor.... My needle has hit 140, but I definitely was not going that fast.

I know when I hit 108 in my SPI (legally on the track of course, moderators [thumb]) there did not seem to be a whole lot left. I could not image getting it up to 125.

Not calling you a liar, just saying it does not jive with my experience.

hope the sensor fixes your issues. let us know.

Ledgerwood_joey 02-08-2013 08:45 AM

Well I'm ordering the part today and I'm almost positive it won't die when it drops rpms because that sensor is like the middle man of the engine and ecu, but my main problem is the really bad vibrating I checked the motor mounts and they seemed fine. Should I still replace them? And for the last 10000 miles the motors been making a ticking noise like the valve seats going out but it's still goin down the road

Ledgerwood_joey 02-08-2013 08:47 AM

And the most important question is should I get the block and head rebuilt or should I just sell the car because its online for $2000 and no one wants it


All times are GMT -5. The time now is 12:07 AM.


http://www.focusfanatics.com/aboutus/copyright.asp