Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   2005 TDCi cuts out (http://www.focusfanatics.com/forum/showthread.php?t=308339)

Theop 02-04-2013 05:48 AM

2005 TDCi cuts out
 
A bit of history:
1. Fuel filter changed last year.
2. Second-hand turbo replacement last year.
3. Car will go into safe mode at speeds over 85MPH - always done this.

Over the weekend the car consistently broke down on me whilst moving/driving, no safe mode this time, just loss of all power and switch off. Any attempts to restart the car, the engine turns but no ignition. After 15 or so minutes, the car would switch on again, as normal. Then, break down again.

This is what happens: as I approach 30 MPH, the engine would lose all power, very suddenly (lurching action), and intermittently and very frequently on/off power. Eventually, it gives up and switches off.

The AA chap mentioned worn fuel injector seals as a possible cause. Someone else mentioned the water pump is at fault.

Any ideas?
Thanks.

Theop 02-04-2013 09:11 AM

Could this be a fuel rail sensor issue, due to high pressure/temperature? That may explain why the car won't start for a while and then, once cooled down, starts?

Theop 02-04-2013 09:25 AM

Another symptom of what may be the problem is that I'm also getting some exhaust fumes in the cabin - not enough to be a major issue but just enough to make me want to open the window! Not good. The AA chap said something about this being a consequence of the injector seals failing? Not sure...


All times are GMT -5. The time now is 08:40 AM.