Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   Overheating/blown radiator hose (http://www.focusfanatics.com/forum/showthread.php?t=307277)

LiquidOC 01-22-2013 05:30 PM

Overheating/blown radiator hose
 
I had a bit of an issue this morning, drove my kid to daycare and the big radiator hose that comes off the thermostat housing blew. Before this I was getting NO heat, and it was really really cold this morning. When I replaced the big radiator hose, I found that the part you guys call a coolant crossover tube is also cracked. How fscked am I? The radiator has fluid in it but doesn't seem to be leaking, I have ordered the new crossover tube. Thermostat and housing was replaced last year with OEM so I have a hard time believing that's what happened...I think something just froze somewhere due to a sub-par mixture of coolant. Please let me know what I should do to diagnose/fix this issue!

Here's what I plan on doing: Flush system with engine running to get all old coolant out while in heated garage or temperature outside is above 35 degrees farenheight, replace busted hose and crossover tube. Hope for the best?

emsvitil 01-22-2013 05:41 PM

You need to fill with pure antifreeze, not the 50/50 stuff.

After flushing, a lot of water stays behind.

Zetecs have a 6.1 qt capacity, so use 3qts of pure antifreeze after flushing.

LiquidOC 01-22-2013 09:18 PM

If the 3 quarts isn't enough to fill the reservoir am I fine to start dumping in the 50/50 blend then?

Also, is there a better place to get the crossover tube than the stinkin' ford dealership? The closest one to me runs annoying ads lol

emsvitil 01-22-2013 09:25 PM

After the 3qts, go with water to fill to the line.


Then 50/50 to make up any slow losses.


All times are GMT -5. The time now is 09:03 AM.


http://www.focusfanatics.com/aboutus/copyright.asp