Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   Alternator problems (http://www.focusfanatics.com/forum/showthread.php?t=306870)

braineatingalien 01-17-2013 07:33 PM

Alternator problems
 
I just replaced an alternator last week that would randomly work and tested bad. Tonight I have having problems again. The car wasn't charging for the entire one hour drive. I was ready to pull it, got it up on ramps and it was charging again.

I have a 2007 ford focus. Does anyone know what could be causing these problems?

freemind 01-17-2013 08:01 PM

The pigtail that plugs into the alt. has gone bad. Or is not seated correctly

braineatingalien 01-17-2013 08:37 PM

I've done multiple wiggle tests and multimeter tests on the pigtail, but it all checks out OK. I think I have the newer style that don't go bad, but I may be wrong. Should I replace it anyway.

amc49 01-17-2013 10:45 PM

Don't be surprised if your new alt is the problem, especially if it is a 'lifetime warranty' one. Those things are often garbage...........

braineatingalien 01-18-2013 09:08 AM

Thats what I was thinking. Its an autozone lifetime alternator.

JayDeZ 01-18-2013 10:44 AM

Quote:

Originally Posted by braineatingalien (Post 4545649)
Thats what I was thinking. Its an autozone lifetime alternator.

When i had my thunderbird back in college (10+ years ago) i was replacing the Autozone lifetime alternators in it ever 2-3 months. I eventually got it down to a 7 min change in the parking lot at the store.


All times are GMT -5. The time now is 11:36 AM.