Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   E-brake locking up? (http://www.focusfanatics.com/forum/showthread.php?t=306739)

onelowsvt03 01-16-2013 11:13 AM

E-brake locking up?
 
recently i noticed that my rear right caliper wasn't working right so i replaced it with no problems. everything worked great so i parked it and the next day as i put the parking brake down, the back right wheel was locked up. i read in a previous thread that you have to adjust the cable which i have done multiple times and it works until the next day it seems, then the wheel locks up again. pretty irratating lol. maybe im not doing something right or there's a trick to adjusting the cable? i dont know, if someone knows of anything please help me out!

SrDudley 01-16-2013 11:31 AM

You might just need to replace your cable...

onelowsvt03 01-16-2013 12:26 PM

Quote:

Originally Posted by SrDudley (Post 4542468)
You might just need to replace your cable...

it could be, but the one on there seems untouched and not damaged, ill for sure take a look at it though, thanks!

LOADED 01-16-2013 02:02 PM

your caliper may be junk. I had the same problem when it got cold, replaced the e brake lines. fixed the stuck brake over the summer, just when it got cold again, it started back up. so it may be your caliper.

jwill2489 01-16-2013 05:25 PM

the cables seize in the sleeves. its just a metal cable in a sleeve. mine are seized. unhook the e brake from the caliper. see if it still does it. im betting it wont. i experienced the same thing. new caliper and all

zetecDon 01-16-2013 05:38 PM

Moved to "General Technical Chat".

onelowsvt03 01-16-2013 07:16 PM

Quote:

Originally Posted by jwill2489 (Post 4543016)
the cables seize in the sleeves. its just a metal cable in a sleeve. mine are seized. unhook the e brake from the caliper. see if it still does it. im betting it wont. i experienced the same thing. new caliper and all

yeah that's what im thinking, just gotta replace the cable?

amc49 01-17-2013 12:07 AM

Or simply figure out how to lube the cable. That thing in water all the time, sooner or later it WILL drag as all cables do left alone long enough.

jwill2489 01-17-2013 05:11 AM

They are seized. Mine haven't been hooked up for over a year. Just leave in gear till you replace. Cable is from the handle to the caliper for svt. Make sire they don't get you zx3 ones

onelowsvt03 01-17-2013 09:55 AM

im probably going to try replacing it this weekend if i have time, ill let you know how it goes!


All times are GMT -5. The time now is 10:58 AM.