Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   Ford Focus & General Car Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=38)
-   -   Scored an MGB,Part 2!!! Say hello to "Downshift"!!! (http://www.focusfanatics.com/forum/showthread.php?t=306634)

mjd4277 01-14-2013 09:42 PM

Scored an MGB,Part 2!!! Say hello to "Downshift"!!!
 
As some of you know,a few months ago I got my hands on a 1975 MG MGB Mark IV roadster. After a few weeks of work(and a [:)][:)][:)][:)][:)][:)]*load of money to boot,lol) the car is in good running order and decent shape. Most of the repair work was done to make sure it could pass inspection here in MA(which it did with flying colors). Pics are finally up on photobucket for all to see.

On that note,here's "Downshift"!!



http://s622.beta.photobucket.com/user/mjd4277/library/

whynotthinkwhynot 01-15-2013 02:15 PM

Yeah, I like MGs, but I don't like their engines or carbs. I have a neighbor with a 71, the year I was born, I hope she finally gets off her high horse and sells it for less than $2500. I like that year because it was the first year with a roll-back roof, and it has the chrome bumpers.

I'd really like a Midget with a Hayabusa engine, but a B or A with a Duratec would be just fine.

mjd4277 01-15-2013 06:55 PM

So far I haven't had any carburetor issues(the previous owner retrofitted a Weber carburetor for better durability and reliability) and the car has started up everytime. You have to remember at that time British Leyland(the former owners of the MG brand) was feeling the pinch from the then new emission and safety regulations just like everyone else. So in order to comply the original dual SU HS-4 carburetors were replaced with a single Zenith Stromberg carburetor. The ride height was increased by 1 inch and the rear anti-roll bar was removed on later models(which compromised some of the handling characteristics of the MGB and Midget). The BMC engines have a reputation of being bulletproof,as long as they're maintained properly(my car is living proof-37 years and 79K miles later it still runs like clockwork).

Peyton 01-17-2013 01:21 PM

My dad had a 75 "b" was a hunk a junk when he got it! He paid 500 for it and brought it home on a trailer! I didnt pay much attention to it when he got it, but i loved it when he was done, he never let me drive it though!! Heres what i recall about it, He took off what he called a strangleburg card and put on twin SU carbs removed the bumpers and fibreglassed on a sebring body kit, lowered the suspension because car sat too high something to do with safety laws and bumpers having to be so high off the ground, Dont know what he did to exhaust, i know there was a header, and exhaust tip was big and shiny! he replaced whole interior as well, car was cherry when he was done, The paint however was far from stock, he did the whole Austin Powers shaguar paint on it! [IMG]file:///E:/Documents/Pictures/My%20Pictures/mg/pre%20restore%201571.jpg[/IMG] [IMG]file:///E:/Documents/Pictures/My%20Pictures/mg/mg%20002.jpg[/IMG][IMG]file:///E:/Documents/Pictures/My%20Pictures/mg/pre%20restore%201496.jpg[/IMG]

hope the pics worked!

Peyton 01-17-2013 01:21 PM

guess they didnt, anyone wanna tell me how to post pics????

Supernaut 01-17-2013 02:24 PM

Quote:

Originally Posted by Peyton (Post 4544474)
guess they didnt, anyone wanna tell me how to post pics????

Click the "insert image" function when writing your post. The image address should appear in the brackets

*asterisk not included*

example

[*IMG]www.yourmgpichere.org/mg71.jpg[*/IMG]

thenorm 01-17-2013 02:25 PM

put the jpeg link of the pictures in between this tag like this
[ img]pic.jpg[/img] expect ignore the space i added to the first tag.


for example
http://i622.photobucket.com/albums/t...psc496f778.jpg

Peyton 01-17-2013 02:44 PM

[img]file:///E:/Documents/Pictures/My%20Pictures/mg/pre%20restore%201499.jpg[/img]

lets see if this works

Peyton 01-17-2013 02:45 PM

im obviously doing something wrong :)

Peyton 01-17-2013 02:47 PM

Quote:

Originally Posted by Supernaut (Post 4544598)
Click the "insert image" function when writing your post. The image address should appear in the brackets

*asterisk not included*

example

[*IMG]www.yourmgpichere.org/mg71.jpg[*/IMG]

i tried that and it wants a web site, all the pics are on this pc.... he has some one car domain but hell if i know where!


All times are GMT -5. The time now is 05:15 AM.


http://www.focusfanatics.com/aboutus/copyright.asp