Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   DURATEC Performance (2003-2007) (http://www.focusfanatics.com/forum/forumdisplay.php?f=41)
-   -   Dogbone install issues need help ASAP (http://www.focusfanatics.com/forum/showthread.php?t=306216)

TKE_Quailman 01-09-2013 06:10 PM

Dogbone install issues need help ASAP
 
Hey i am midway install in the dark getting eaten by mosquitoes is FL and im installing a CFM ply dogbone mount and i have run into 2 issues 1) it looks like my tranny doesn't align with the body mount. 2)The CFM mount wont go into the tranny mount like if the poly urethane bushing is to large it gets 85% in and then gets stuck i dunno if i should grease it up and try and shove it in there.

Also i have a 2007 manual i am 100% i ordered the correct mount just checked my order with CFM

macdiesel 01-09-2013 06:19 PM

Pry bar, wood block and hammar will be your friends with this install.

mashore81 01-09-2013 06:35 PM

I did a poly bushing swap by myself at night. when I needed that extra push I started the car up and rocked the engine. Probably not recommended but I had work in the morning. Good luck.

macdiesel 01-09-2013 06:38 PM

You don't need to start it up? Can also use a jack under the trans to help manipulate the position.

rambleon84 01-09-2013 08:04 PM

Quote:

Originally Posted by macdiesel (Post 4533069)
You don't need to start it up? Can also use a jack under the trans to help manipulate the position.

that's what I had to do. needed lots of help getting it lined back up. pita but worth it. just have to use force, be good to have some one else helping, wasn't easy with the car only on jack stands getting leverage

sleepyboy 01-09-2013 08:07 PM

Yup, I used a jack to help align it as well, though other times I didn't. Have you ever replaced your passenger side? I know mine was worn out and was letting the motor sit a lot lower than it should have.

Svt_kid 01-09-2013 08:59 PM

yea jack it up and manhandle it into place. Best part about these engines is when you take off the motor mounts everything shifts position.[?|]

zetecDon 01-10-2013 12:38 AM

Moved to "Duratec Performance".

TKE_Quailman 01-10-2013 10:54 AM

http://i.imgur.com/bXSfs.jpg

Still not going in i am open to ideas and suggestions
tools used a jack and a crowbar so far and nothing

Also while down there i discovered my flex pipe was broken =(

rambleon84 01-10-2013 01:10 PM

Well my experience isnt going to help, I had the opposite problem. Those two points were too close and I had to push the engine away. Along with my floor jack and a block of wood under the tranny/engine to support/move the weight while trying to get it to line up

If you raise the car higher/lower, will that create a pivot and let gravity push those two points closer? (I'm trying to orientate myself to that picture, front of the car is to the right, correct?) Do you have any ratchet straps you can hook around the subframe and engine to pull those two points closer?

No idea if either of those are viable or dumb...just throwing out ideas. I'm getting the impression you are working on this yourself. Glad you stopped on it last night, sounded like it had be super frustrating (I know i had to sleep on mine after not getting it done the night i tried to install it.)


All times are GMT -5. The time now is 07:03 PM.


http://www.focusfanatics.com/aboutus/copyright.asp