Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   MK2 Focus (http://www.focusfanatics.com/forum/forumdisplay.php?f=120)
-   -   Issue with Eagle Eyes and HIDs. (http://www.focusfanatics.com/forum/showthread.php?t=306214)

Dukttape 01-09-2013 05:53 PM

Issue with Eagle Eyes and HIDs.
 
I bought a set of Eagle Eye Projector headlights and have DDM HIDs in them. 2 complaints. 1 my high beams worked for a good 6 months popped a fuse and now continue to pop fuses, so they "don't work". 2 the cut off "line" is more like a scoop, so I have them aimed low so I don't blind oncoming traffic. Any solutions would be much appreciated.

crice8 01-09-2013 06:43 PM

They are halogen projectors which is why your cutoff looks like that. Mine does it also. As for the high beams, do you have the bixenon hids? I only have the regular 55w ddm tuning hids and the high beams are not a more intense light but rather the shield that makes the cutoff activates when the high beams are switched on and allows the full light out.

Dukttape 01-09-2013 09:05 PM

I have the 35W 5000k H9s. The flap worked for the first 6 months then popped the high beam fuse. I replaced the fuse and it popped it again. So sadly I don't know what to do about it.

A7xschecter6661 01-09-2013 10:44 PM

check all your wiring for shorts causing the fuse to pop. That's why I'm glad I went retrofit instead of eagle eyes though.

The output is a ton better.


All times are GMT -5. The time now is 08:30 PM.