Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   battery light issue (http://www.focusfanatics.com/forum/showthread.php?t=305372)

mddunlap03 12-31-2012 10:05 AM

battery light issue
 
so my charging system light is on. turns on after running for a bought a minute. batter checks out good on load tester (mine does not have an amp probe :( . with car running voltage is 13 + volts at idle at 2000 rpm under load is 14-14.5 . plz help

also are i have heard these are clutched i dont think that to be true but is it ?

mod Big 3 wire upgrade, fs werks 2.5 cat back, zx 500.1 amp x2, k and n on maf tube

svtguy88 12-31-2012 10:07 AM

Check the 3-pin (I think) going to the alternator - notorious failure point that will give you a battery light. The wiring to the connector or the connector itself are common parts to break. Took me forever to find it when it happened to me.

If that's the problem, you can get a harness repair kit and solder on a new section of wire/connector.

mddunlap03 12-31-2012 11:36 AM

not the connector
 
pulled apart and cleaned wires look good still have the light with all the acc on and load tester at a 100amp at idle it drops to 12v with no tester 13.5 - 14.8 idle /2000 rpm lost on this one found a broken wire on valve cover going to a small black box maybe a 14-16 gauge wire both black one goes to ground other into a harness my guess is its a superuser for injectors or coil ? any one ?

mddunlap03 12-31-2012 05:47 PM

ok the car was reading 14.3v at idle replaced alt never breaks 14v but light is off so yey lol


All times are GMT -5. The time now is 10:55 PM.