Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   2000 Focus Vents Stuck? (http://www.focusfanatics.com/forum/showthread.php?t=305120)

2000FFocusLX 12-27-2012 05:20 PM

2000 Focus Vents Stuck?
 
The vents in my 2000 Focus LX are stuck on defrost. Still works on all 4 speeds and the heat works. By stuck I mean stuck. It WILL NOT switch out of defrost. I broke one switch trying, then went down to where to switch connects and tried down there too. No movement whatsoever.

Any idea what is wrong with it and how to fix it?

The switch is the vent selector: defrost, feet-face, feet, face. It is NOT the switch itself. PLEASE ANYONE WITH KNOWLEDGE HELP. I've been dealing with this for well over a year now and Really need this fixed for winter, I am moving to north dakota in less than a month and cannot afford to pay a dealership $800 for a small fix like this (I know dealerships Especially Ford really try to screw you with parts and labor).

MEJY1988 12-27-2012 09:29 PM

I am no expert but, you may want to check out the following:
Does your vent selector stick? Have you broken the cables? Read on,

Hope it helps. Good luck.

2000FFocusLX 12-28-2012 02:21 AM

Thanks for the reply! That does help out, but he didn't completely specify. It might be a vacuum leak I'm thinking.. because it is stuck in defrost.. I'm going to pull the glove box off tomorrow and see if I can find out if anything is blocking the vents, I hope so. Because I have no idea what I'm doing. Anyway, more help would be appreciated.

whynotthinkwhynot 12-28-2012 06:07 AM

Focus vent selectors are controlled by a cable, not vacuum. Be thankful, vacuum actuated controls are not fun to diagnose problems on.

rsnow 12-28-2012 08:31 AM

yes they are cables, check the selector cable, may be stuck, look where it attachs to the blen door box

2000FFocusLX 12-28-2012 03:35 PM

Quote:

Originally Posted by rsnow (Post 4515240)
yes they are cables, check the selector cable, may be stuck, look where it attachs to the blen door box


I already snapped the cables, when I was replacing them I tried manually changing it with the selector down by the blend door box on the outside, and the thing will not turn at all... The cables are not the problem. I already snapped and replaced them. The problem is whatever is behend the switch Which I have no idea how to check or anything.

mark315 12-28-2012 03:54 PM

I have the same problem with my '07. I replaced the Bowden cable. The upper blend "lever" that is part of the heater box works fine. However the lower blend lever is stuck. Does anyone have steps to access the heater box so I can remove the obstruction? I'm not sure blowing air in through the blower motor opening will work as it seems pretty far away from the problem area.
Thanks

2000FFocusLX 12-28-2012 04:07 PM

Quote:

Originally Posted by mark315 (Post 4515790)
I have the same problem with my '07. I replaced the Bowden cable. The upper blend "lever" that is part of the heater box works fine. However the lower blend lever is stuck. Does anyone have steps to access the heater box so I can remove the obstruction? I'm not sure blowing air in through the blower motor opening will work as it seems pretty far away from the problem area.
Thanks

Is yours stuck on defrost also?

mark315 12-28-2012 04:23 PM

I can get 2 positions. Defrost and vent. No heat at floor, no defrost/heat mix.

2000FFocusLX 12-28-2012 05:14 PM

Hm. That's how mine was before it got stuck on defrost. I'm betting something is blocking the vents from changing


All times are GMT -5. The time now is 01:25 PM.