Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   SVT Performance (2002-2004) (http://www.focusfanatics.com/forum/forumdisplay.php?f=40)
-   -   messed up dogbone mount point on tranny (http://www.focusfanatics.com/forum/showthread.php?t=304418)

yjman92 12-15-2012 01:21 AM

messed up dogbone mount point on tranny
 
i just bought an 04 svt and i found this tonight. someone jerry rigged it and i rock the whole engine with ease. it looks like someone did a terible job of re drilling the hole and messed up the whole mount

http://imageshack.us/a/img228/6071/photo121419241.jpg


http://imageshack.us/a/img831/3126/photo12141924.jpg

yjman92 12-15-2012 01:22 AM

the whole bolt moves around

sleepyboy 12-15-2012 01:53 AM

Yikes!

yjman92 12-15-2012 01:57 AM

any suggestions lol

tukaniSVT 12-15-2012 07:17 AM

That's going to be a mechanic fix and see what they can tell you. That's not a DIY fix at all.

Ray

yjman92 12-15-2012 08:12 AM

i was afraid of that

macdiesel 12-15-2012 08:29 AM

That looks like a mechanic fix. Hope a new trans is not needed.

yjman92 12-15-2012 02:21 PM

at worst should be able to weld iin the hole and start fresh with anew whole and fresh threads i hope. its drivable s ill see what can be done

HilloNative 12-15-2012 02:53 PM

Wow ! Hope you don't need a new transmission , I didn't even dare to try something like that in my old escort.

iminhell 12-15-2012 03:38 PM

Looks like ready-rod.
Pull it out and see if you can just get by using a bigger rod.

The PO must have been a real smart person [facepalm]


All times are GMT -5. The time now is 05:40 PM.


http://www.focusfanatics.com/aboutus/copyright.asp