Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   So i'm new~ and i have a question. (http://www.focusfanatics.com/forum/showthread.php?t=304012)

sarah7x 12-09-2012 09:12 PM

So i'm new~ and i have a question.
 
Ok, hi :) I'm new on here, i kinda found this page through google, but it looks like it'll help me out a lot :D

So, I bought an 05 ZX4, and I've had a couple problems since I got it. At first, the air filter box was [:)][:)][:)][:)][:)][:)] up, so I put an intake on the car, then they gave me the car all [:)][:)][:)][:)][:)][:)] up so I had to pay for a couple other things to get switched out. Now, the check engine light turned on and I thought it was my intake cause I was having problems with it staying on but it was fixed, so I went to auto zone so they could check my car. I got 2 code, one of them was for the first oxygen sensor. That's ok cause I know how to do that.

But, I got another code, the P0622 code. I was looking it up and it could be my alternator? Cause it says it could be a circuit problem, but my battery light has been on since I got the car O:
So, I dunno, Does anyone know what it could be?
Any help or advice or anything would be awesome c:
Thanks;)

zetecDon 12-09-2012 11:34 PM

Moved to "General Technical Chat". As for the P0622 code it sounds as if the wiring harness to the alternator has gone bad and needs to be replaced. These have been known to go bad over time and are easy to fix. But as always, have everything checked to make sure that is the problem.


All times are GMT -5. The time now is 12:12 AM.


http://www.focusfanatics.com/aboutus/copyright.asp