Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   4 days old and check engine light?? (http://www.focusfanatics.com/forum/showthread.php?t=303620)

kbnholden 12-04-2012 12:02 AM

4 days old and check engine light??
 
I got my 2013 Focus 4 days ago, and it was love at first sight/drive. And, no joke, my check engine light is on. Have the fancy myFord Touch thing, and ran the diagnostic. Said to open and close my fuel door. Light is still there.

When accelerating from a stop, the car seems to kind of chug, almost, like it's not connecting with the gears, or is slipping somehow. Maybe a fuel problem? When I get going, it's fine. I noticed that my gas mileage and usage was TERRIBLE and think that they are all somehow related.

Going to call dealership tomorrow (just got home from work an hour agoish), but am devastated.

Has this happened to anyone?

Screachin93 12-04-2012 12:42 AM

Check your fuel cap make sure its on right some of the newer cars are kinda funny about the fuel cap because of the emissions

kbnholden 12-04-2012 12:44 AM

I did, but I have a capless fuel thing. I opened and closed the little door twice. Still no change.

whynotthinkwhynot 12-04-2012 06:26 AM

Something is wrong with the capless fuel cap or the EVAP emissions system. The dealer will replace the part and that will fix it. That's what warranties are for.

kbnholden 12-04-2012 09:25 AM

waiting on a call back from their service department. it's been 10 minutes. apparently they're busy.

I agree that it feels like something fuel related. When the tank was full, there was none of this stuttering as I accelerated from a stop. It's gotten worse as the tank has gone down.


All times are GMT -5. The time now is 06:22 PM.