Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   SVT Performance (2002-2004) (http://www.focusfanatics.com/forum/forumdisplay.php?f=40)
-   -   2004 Foucs SVT knocking under acceleration (http://www.focusfanatics.com/forum/showthread.php?t=303082)

miller1m2001 11-26-2012 12:29 PM

2004 Foucs SVT knocking under acceleration
 
I'm not a new member but this is my first post. Any help would be appreciated. I try to do all of my own automotive work, been tinkering with cars/motorcycles for the last 35 years so I know my way around a car.
What I've got is this.
I own a 2004 Focus SVT ZX3 with about 170,000 miles. Car runs great but suffers from the usual aches and pains for a car it's age and mileage. I have a repetitive knocking sound which started out as a very low tapping sound and happened only when I accelerated. I have seen postings here with similar issues but no fixes that I haven't already tried. The noise has gotten louder and worse since then. It happens when accelerating or slowing down, only when the clutch is out (engaged). The sound is in all gears and gets faster as the RPM's go up. I don't think it's the motor but who knows.
I have already replaced both drive axles, both side wheel bearings and both side lower ball joints. Didn't fix the problem.
I has told when I bought the car that the clutch had just been replaced and I haven't had a problem with it but you know how that goes.
Because of the high mileage and me wanting to keep the car (love driving it) I knew I wanted to replace the timing belt and water pump, as well as the front and rear main seals so I pulled the engine/trans and when I seperated the two the throw out bearing and spring came off the end of the transmission output shaft like a jack in the box. I am hoping this is where the knocking was coming from but time will tell.
I ordered the front and rear main seals as well as the clutch slave/with throw out from Tousley Ford, a really great place to deal with. parts should be here tomorrow.
just trying to see if anyone has any other ideas on what my problem could be.
Thanks


All times are GMT -5. The time now is 02:04 PM.


http://www.focusfanatics.com/aboutus/copyright.asp