Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   SVT Performance (2002-2004) (http://www.focusfanatics.com/forum/forumdisplay.php?f=40)
-   -   Electrical button related flicker (http://www.focusfanatics.com/forum/showthread.php?t=302763)

SVT513 11-21-2012 02:15 AM

Electrical button related flicker
 
My SVT's odometer area on the gauge cluster and headlights flicker if i click any of the electrical buttons inside the car. (horn, window buttons, etc)

I just recently realized it while i was parking and had the headlights on and clicked the window up buttons to make sure the windows were up before i got out of the car. That was when i saw the connection that every click of a button- resulted in a flicker of the headlights and gauge cluster area.

Little background- About 3 months ago, i bought a big 3 upgrade kit from Ray and installed the 2 grounds only. Still havent gotten around to doing the upgraded postive cable. Also, the car is still stock...nothing extra added to the electrical system that would pull more energy from the car/alternator/battery.

Before i bought the car, about a year and a half ago- the alternator was replaced.

My thoughts: BAD/defective alternator, bad ground connection, not installing the upgraded positive cable yet, or jacked up wiring.

What do you guys think?




Thanks guys as always!

jwill2489 11-21-2012 07:02 AM

mines been doing it for quite a while. had everything tested and its all fine. no idea

smallblockfever 11-26-2012 09:08 AM

I have a similar problem, i believe it is the volatge regulator. Im interested to see what it ends up being for you. Wish i could help.

SWEGER 11-26-2012 09:41 PM

Mine has been kind of going from bright to dim and back and forth for a while now. Had a new battery, alternator, and pigtail installed in January. No idea what is causing this. It seems to not do it at 3000+ RPMs, or after a while of driving.

StephenElsbree1986 11-27-2012 06:52 AM

Alternator related

SWEGER 12-02-2012 05:46 PM

Thanks. Good thing it has a lifetime warranty from Auto Zone then...I'll go have them check it. Too bad it was a pain in the butt (time consuming, and that damn serpentine belt) to change.

SVT513 12-07-2012 10:35 AM

Are you sure you can just point this this alternator related? I have a brand new alternator and it measures the correct voltages.

I think it has to be something else, my car is showing ZERO signs of a bad alternator...only has the above problems. (Original post)


All times are GMT -5. The time now is 04:38 AM.


http://www.focusfanatics.com/aboutus/copyright.asp