Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   Electrical Issues (http://www.focusfanatics.com/forum/showthread.php?t=302517)

blakeclevenger 11-17-2012 08:08 PM

Electrical Issues
 
My 2002 ZX5 has had some electrical issues for a while. Now they are starting to mount up and its time I fix it.

1. Year ago, the radio started getting bad reception on FM. I don't listen to this much, so I don't really car.

2. The lights are crazy dim. Yes I have replaced the bulbs and cleaned the lenses but it doesnt seem to make a difference. I also changed the dimmer switch and looked for a ground problem. May be I am missing one of the grounds, but I cant see an issue here. I live in the city so the street lights help a bunch. I have just tried to live with this. I use the fog lights to help. (Brights seem to work ok).

3. For the past few months, when i make the right turn into our alley and hit a bump, the open door switch comes on and kicks the dome light on. Obviously, no door is open. I checked the four door switches near the latch where it indicates that the door is closed. All four seem to work on and off. Now may be one isn't working well, but I am having trouble isolating this. Additionally, I cant find this switch for the hatch/trunk. I am wondering if this is where the problem is.

4. This might be related to the problem addressed in #3, but my passenger door lock went crazy. At random, the doors would try to lock when I was going down the road. I know that the car is set up to lock once you travel above a specified MPH, but it would keep doing this over and over. I assume this is do to the door open situation. Next thing I know, the passenger door lock starts making a terrible electrical/grinding noise. Then a day later, the door lock is seized. I couldn't open it from the inside or the outside. After jamming a screw driver down in the door, I got it to release (not sure how, but my prayer was answered. I changed the latch and motor (one piece) yesterday. (I have turned off the auto-lock now).

After changing the latch and motor, it now locks and unlocks. The problem is that if the door has been locked, it must be unlocked from the inside using the handle. Once this has been done, then the door will open over and over using the outside handle. Is there a linkage issue?

Im stumped. Any help is greatly appreciated.

mikebontoft 11-17-2012 08:36 PM

You know your other problem is likely related to this as well...

what do all of your little grounds look like that bolt to the fender right next to the battery?

blakeclevenger 11-17-2012 08:39 PM

I checked one ground and it looked good. Is there a good diagram on here that shows where all the grounds are?

I assumed the idle situation wasn't related to this because it was new, but heck, Im not sure. The electrical thing is a demon. I just keeps expanding it seems. Been going on for years. My only complaint about the car other than the faulty plastic in the rear window regulators.


All times are GMT -5. The time now is 09:12 PM.


http://www.focusfanatics.com/aboutus/copyright.asp