Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   Focus Tuning Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=79)
-   -   Datalogging AEM Digital Boost Gauge (http://www.focusfanatics.com/forum/showthread.php?t=302480)

mj22 11-17-2012 05:20 AM

Datalogging AEM Digital Boost Gauge
 
Hi Guys,

I was just wondering if anyone has had any success datalogging the analog output from an AEM Digital Boost Gauge (30-4406).

I have wired up my Xcal 3 to datalog the analog output, 0-5 volts that the gauge supplies and attempted to apply this equation to the raw voltage signal:

*Equation*: PSIA=12.5*(volts)-6.25* scale: .5v-4.5v = 0-50psia

which should then provide the boost.

I'm running a JRSC which sees 10 psi at redline. The boost level is indicated on the gauge however applying the formula to the analog output I don't get an accurate boost figure to datalog.

Can anyone advice an amendment to make to the above formula or possible reason the analog output may not be providing an accurate signal for datalog?

Thanks for the help.

Mike

1turbofocus 11-17-2012 07:59 AM

If you go to commands in your live link , then do the drop down to the right and choose your AEM in the list then click apply you should have th correct equation

This has been correct for me about 99% of the time , Have you tried that ?

Tom

mj22 11-18-2012 07:24 PM

Hi Tom,

Yes I have tried that.

The figures I am getting back don't match what is indicated on the boost gauge.

I will post up some figures from the datalog later, however if I start the datalog with accessories on but prior to turning the engine on, the datalog for the AEM boost gauge (with the equation applied to the RAW 0-5 v) returns a value of around 13. Obviously with the car off this value should be 0.

I will re-check the wiring tonight however I don't see this being the problem. I will also complete a datalog of all analog inputs 1 to 4 to see if it is somehow being picked up on one of the other analog inputs. I don't think this will resolve my problem either as the analog input 2 is reading between 0.5 and 4.5 volts as AEM advise the analog output fror their boost gauge should.

I've had no issues datalogging the AEM wideband by applying the formula through livelink.

Thanks,

Mike

mj22 11-19-2012 06:48 PM

Hey All,

Is anyone aware if the analog signal provided by the AEM Digital Boost Gauge provides an absolute pressure. ie. atmospheric pressure plus the pressure created by the supercharger/turbo etc?

If this is correct I am at or around sea level so I have an approximate atmospheric pressure of 14.7 psi.

If this is the case I would need to modify the formula applied to the raw 0-5 volts from the AEM boost gauge to be "[(12.5*v)-6.25]-14.7". Anyhow applying this formula the boost levels I am datalogging appear significantly more accurate.

Can anyone confirm if this correction for atmospheric pressure is required?

Thanks,

Mike

NJSVTGUY 12-29-2012 08:47 AM

I would think it would. Why don't you use a 2 or 3 bar MAP? Like you mention the first bar is for atmospheric. If running under 14.7 you would just need a 2 bar, over a 3 bar.


All times are GMT -5. The time now is 08:31 PM.


http://www.focusfanatics.com/aboutus/copyright.asp