Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   need help got some problems with my svt (http://www.focusfanatics.com/forum/showthread.php?t=302452)

sally03svt 11-16-2012 04:39 PM

need help got some problems with my svt
 
Well my car wants to pull hard to the left our right when i accelerate our when i go around turns. it sucks and im afraid its going to cause an accident cause it turns very hard left our right gotta fight every time i turn. ihave zx3 rims with 205 55 r16 on them pretty much my winter tires and rims it never happened when i had rims on it d

tukaniSVT 11-16-2012 06:45 PM

** Moved to the General Tech Chat Area **

Sounds like your car may have an alignment issue.

When was the last time you aligned your car?

If recent, check your tie-rods and CV Joints and make sure you don't have any major wobble on your front wheels with the car up in the air. Also look at the top hat of your front suspension and make sure that doesn't move when you have in the air also.

Ray

sally03svt 11-16-2012 07:02 PM

Both wheels did wobble a little when in the air tie rods and cv joints seemed to be ok had the car since feb of this year havent had an alignment since ive had it.

hEaT 11-16-2012 07:19 PM

Quote:

Originally Posted by sally03svt (Post 4459215)
Both wheels did wobble a little when in the air tie rods and cv joints seemed to be ok had the car since feb of this year havent had an alignment since ive had it.

Was the wheel locked? Was there any play in the joints themselves? When inner tie rods go you'll get a similar pull on accel and decel. Get an alignment and they'll tell you if they can't due to worn parts.


All times are GMT -5. The time now is 11:52 PM.


http://www.focusfanatics.com/aboutus/copyright.asp