Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   North East Fanatics (http://www.focusfanatics.com/forum/forumdisplay.php?f=15)
-   -   Saleen Ford Focus S121 Help!!! (http://www.focusfanatics.com/forum/showthread.php?t=301860)

FatPete96 11-09-2012 07:40 AM

Saleen Ford Focus S121 Help!!!
 
I'm curious on something. I have a 2005 Saleen Focus S121 and whenever I hit like a speed bump or a rough part of the road and I'm not going 5 miles an hour it is REALLY rough and the suspension is making a decently noticeable noise. The car is not bottoming out or anything, it almost feels like the suspension is just so stiff. Is this normal or do I need to get that checked out? And if I do need this checked out does anyone know a good spot on Long Island that I can go to that's reputable or can someone in the area meet up with me and help out? Thanks for all the help!

loc0gring0 11-10-2012 09:45 PM

The ride is deff solid in a saleen.. Check your sway bay end links. And make sure the 3 bolts on the top of the strut are tight..

qweesy 11-11-2012 01:03 PM

thats because saleens came with the full poly kit installed, avoid pot holes and slow down on bumps

TitanFocus76 11-11-2012 04:32 PM

could possibly have a blown shock or strut

hEaT 11-11-2012 08:39 PM

Quote:

Originally Posted by qweesy (Post 4450524)
thats because saleens came with the full poly kit installed, avoid pot holes and slow down on bumps

Pretty sure it was just the Eibach Pro Kit (badged as Saleen).


Did you just get the car or has this gotten progressively worse? The Pro Kit will ride harsher than any factory Focus suspension.

FatPete96 11-12-2012 11:14 AM

I just got it. It has been consistent since I got the car. I'm gonna have the end links and struts checked out. Thanks for the advice though.

loc0gring0 11-14-2012 05:33 PM

its the eibach pro kit.. nothing is poly in the suspension.....

something is deff wrong.. blown strut or something being warn..

mine is very stiff but doesn't make any noise over bumps

SaleenT121 11-16-2012 08:52 AM

Quote:

Originally Posted by loc0gring0 (Post 4455795)
its the eibach pro kit.. nothing is poly in the suspension.....

something is deff wrong.. blown strut or something being warn..

mine is very stiff but doesn't make any noise over bumps


It has Poly pivot bushings on the anti-roll bars....

hEaT 11-16-2012 01:50 PM

Quote:

Originally Posted by SaleenT121 (Post 4458347)
It has Poly pivot bushings on the anti-roll bars....

Yeah, that's it, but that's also a pretty standard upgrade. On all the control/trailing/toe arms it's all standard parts.


The ride will be stiff, but should be quiet. Check ball joints, upper strut mounts/bearings and front sway endlinks.

DognamedMack 11-17-2012 10:45 PM

Quote:

Originally Posted by FatPete96 (Post 4451775)
I just got it. It has been consistent since I got the car. I'm gonna have the end links and struts checked out. Thanks for the advice though.

I know the 00-04 have end link noise when they start to go out. I think the 05 has a lot of the same parts as the 00-04 suspension.

The end links will sort of rattle at low speeds (under 20 or so) going over bumps. Don't usually hear them at highway speed.


All times are GMT -5. The time now is 03:49 PM.


http://www.focusfanatics.com/aboutus/copyright.asp