Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   DURATEC Performance (2008-2011) (http://www.focusfanatics.com/forum/forumdisplay.php?f=329)
-   -   CAI causing issues... (http://www.focusfanatics.com/forum/showthread.php?t=301224)

miscreant 11-01-2012 03:04 PM

CAI causing issues...
 
Hey guys,

Got a lovely 2010 SES a few months ago and it's such a beauty that I wanted to start modifying it. Anyways I got a K&N 69 Typhoon CAI (the one their website says is for the 2010 SES) and install went great. Car sounded great, felt a little more pick up, no problems.

That was a week and a half ago, then a few days ago at around 1500 rpm it seems to judder and won't switch overinto higher gear (automatic) unless I floor it and let the overdrive kick in and it still doesn't sound quite right.

What do you think, is this a transmission problem that just cropped up at the same time or is the CAI messing with stuff? I haven't gotten a flasher yet, was gonna wait til I installed the exhuast.



I did call K&N and the lady I talked to seemed to think I got the wrong CAI, that because I had a TiVCT engine K&N didn't have one. Now I know I am knew to this, but I'm pretty damn sure I have a normal Duratec 2.0L.

Buickboy 11-01-2012 03:22 PM

yeah you dont have a tivct engine.

did you leave the battery disconnected for 10-15 minutes to reset the comp?

make sure everythings tight. if you want to see if its tranny related just swap back to the stock setup for a few days to test.

miscreant 11-01-2012 03:34 PM

I kept it disconnected while I was installing it, which took an hour or so. Ahh I see what she was talking about, she didn't say T-Vict, she said PZEV.

indy_11 11-02-2012 12:07 AM

it's happened before to alot of ppl on here. my focus is a manual but when i'm in a 3-5 and at a low rpm it starts to sputter. thats just the nature of not having a tune i suppose.

miscreant 11-02-2012 12:52 AM

So tuning it, either getting it professionally done via Tom, or getting a flasher from say FSWERKS will help alleviate the problem?

jetrinka 11-03-2012 07:37 PM

Memory is a bit fuzzy here but wasn't there a difference between the 05-07 and 08-11 MAF tubes? Steedas SRI kit came with a removable insert of sorts for this reason?

K&N also had issues with their MAF tubes being off in diameter, throwing off the MAF reading a bit. Perhaps this issue is present with this intake as well?

I wouldn't think you would need a tune to deal with just an intake. You are not drastically changing anything from stock except a more direct, and free flowing path of airflow to the engine and the cars adaptive learning strategy should be more than able to compensate.

I would start by making sure everything is tight. Make sure the MAF is in the right way. If those conditions are met, I would pull the MAF out and look at the sensor wire in it and see if it has been contaminated by the filter oil. If its oiled too much, oil film can make its way onto this wire, bake on it and cause bad readings. Take some special MAF cleaner to it if you suspect its dirty at all.

miscreant 11-04-2012 01:28 AM

When I e-mailed K&N the person that was helping me decided to send me an MAF harness that should work, so it sounds like she thought that was the issue too.

I had reset the ECM again and let it learn the idle trim again and it fixed the problem mostly, still does it a bit but not as bad. I'm going to install that MAF harness and see if it does the trick.

Buickboy 11-04-2012 09:30 AM

Quote:

Originally Posted by miscreant (Post 4435583)
So tuning it, either getting it professionally done via Tom, or getting a flasher from say FSWERKS will help alleviate the problem?

go with FSW. youll thank me

indy_11 11-04-2012 09:33 AM

from the people i've talked to with tunes, they say their car runs fine. the people without tunes have this issue. i even had it when i took the airbox resonator off. i wish i could get a tune so i could tell you if that is the case, but i'm low on funds

miscreant 11-04-2012 11:25 PM

That causes me a dilemma then....get a flasher and tune, or get an exhaust...


All times are GMT -5. The time now is 08:05 AM.


http://www.focusfanatics.com/aboutus/copyright.asp