Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   MK1 Focus (http://www.focusfanatics.com/forum/forumdisplay.php?f=45)
-   -   Fuse 32 keeps blowing (http://www.focusfanatics.com/forum/showthread.php?t=300451)

Jamesnorge 10-22-2012 01:12 PM

Fuse 32 keeps blowing
 
Hello
I'm hoping that one of you Foci experts will be able to help me with this problem.

Car affected is a British mk1 1999 Ghia.

I was out for a drive to get the groceries and when I was coming back home I noticed that the dash lights weren't on even that my headlights were.

I checked the fuses when I got home and found Fuse 32 had blown, the handbook says that this fuse is for the light switch.

Items affected by the light switch fuse blowing were, the instrument panel and heater lights, the tail lights, number plate lights and front parking lights. I think it also affects the wing mirror to some extent.

I changed the fuse and all came back to life for about two minutes when the fuse blew again.

I checked the wiring in the boot (trunk) and this looks like new from what I could see of it.

Checked the earth points in the engine bay, the one near the battery looked great but had to clean up the one opposite the steering pump.

Changed yet another fuse and all came back to life again for another few minutes.

A bit stumped at this stage.

Can you help???

pasta 10-23-2012 06:08 PM

did you check the light switch

Jamesnorge 10-24-2012 07:27 AM

Hi,

I took the switch out and cleaned the connections. Still the fuse blew after doing it.

What I have noticed is that when I put on the fog lights, it seems to draw power away from the headlight on the drivers side.

As far as I can tell, they are on seperate circuits and the only place that they meet is in the light switch.

So I'm fast coming to the idea that a new switch is the answer.

I have ordered one with fancy led's from ebay.


All times are GMT -5. The time now is 12:45 AM.


http://www.focusfanatics.com/aboutus/copyright.asp