Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   need help (http://www.focusfanatics.com/forum/showthread.php?t=299639)

j2blaze420 10-11-2012 08:57 PM

need help
 
i cant figure out why my car is idling rough and low and acts like it wants to stall i replaced plugs and upstream o2 sensor since thats what the cel said it was and replaced egr sensor and line any ideas on whatto do next would be helpful

rangerbay 10-11-2012 09:07 PM

Check you hoses for crimps or leaks. Then check to make sure you're getting spark to all cylinders.
I had a crankcase vent tube crimp causing a bad idle. It was crimped at the rear of the motor, you had to follow the rubber tube to the back to find it. It starts out as ametal tube from the crancase, drivers side front, and goes into a rubber tube under the thermostat housing. Follow it from there. That could be your problem.

Bill

duc450 10-11-2012 11:59 PM

Might want to also check tps sensor readings and idle air control valve. I've also seen a weak alternator cause similar symptoms.

j2blaze420 10-12-2012 03:46 PM

how would i go about checking to see if im getting spark to all cylinders im not gonna lie im no mechanic but i refuse to pay tons of money to have a shop look at it

rangerbay 10-12-2012 04:53 PM

Turn the engine on, then barely pull one plug wire off the coil pack and keep it right at the tip of coil. Spark should jump the the plug wire. Do that for all 4. If you're getting spark there, then check the spark at the spark plug, same way. If you have spark at the coil, but not at the plug= bad plug wire.

Did you check the hoses? That is the first thing I'd check.

Bill

j2blaze420 10-15-2012 12:40 PM

i checked the hoses couldnt find a leak i was gonna try and check the iac do you know the easiest way to remove it


All times are GMT -5. The time now is 09:47 AM.


http://www.focusfanatics.com/aboutus/copyright.asp