Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   2005 ZX3 "turns off" when braking from high speed (http://www.focusfanatics.com/forum/showthread.php?t=299341)

Squishy Crayons 10-08-2012 10:02 AM

2005 ZX3 "turns off" when braking from high speed
 
I recently got a lot of work done of my '05 ZX3. Had the clutch and clutch plate replaced, the tire stabilizer links replaced, and the driver's side CV joint shaft assembly replaced.

It's still got a check engine light that I haven't had time to check out yet, but the car runs fine, except for one thing. Whenever I'm braking from a high speed in 4th or 5th, I put the car in neutral and just coast/brake to stop. But now, sometimes, the battery and oil light appear beneath the steering wheel and everything locks up. Power steering turns off and brakes become stiff. I have to turn off the car and start it up again.

So far it's only happened at red lights and turns at red lights, but it's very dangerous because I can barely turn the wheel. I don't want this to happen when I'm trying to get off the interstate of something. Any ideas what the problem could be?

BC_ZX3 10-08-2012 06:01 PM

When the engine stalls, you lose engine vacuum that helps power your brakes and steering. The oil pressure and battery light coming on is normal since the engine is off. That part is simple to explain.

If the engine stalls suddenly only during the application of the brakes, check the wiring in the rear hatch between the hatch lid and body for shorts. Lots of info about it on here. There may be an electrical short.

If the engine stumbles and then stalls, check for a large vacuum leak in the induction system after the MAF sensor.

Get the DTC (check engine light) code read as soon as possible as that may give you a clue as to the problem.


All times are GMT -5. The time now is 11:33 AM.


http://www.focusfanatics.com/aboutus/copyright.asp