Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   Is this normal? rpms seem to hang (http://www.focusfanatics.com/forum/showthread.php?t=299209)

perkgana 10-06-2012 04:25 PM

Is this normal? rpms seem to hang
 
So I've been riding a lot about this and I cant find a satisfying answer.

Watch the video.

http://youtu.be/541eya3QYqc

The car is already warm. when you rev it the engine revs up and down normally but hangs at abour 1200 rpms for a WHILE and then drops down to 800 (normal) is that normal? This is my first used zx3

Also when I am driving, lets say I want to come to a complete stop so I let off the throttle for a while watch the engine rev down a few hundred rpms and then when I press the clutch to shift out of gear it revs up on its own.. about 200-400 rpms.

Also when I let off the throttle to use the engine to slow down it seems to hang at 2000 rpms for a loooong time.

Are this issues normal on a ZX3 ???? (2000 with 90k miles)

If something is wrong, any idea what? I tried finding vacuum leaks but no luck and I used seafoam to see if that helps and nothing either. Cleaned the Throttle body too (which was nasty).

Thanks!!!!

zetecDon 10-06-2012 10:20 PM

Moved to "General Technical Chat".

whynotthinkwhynot 10-07-2012 12:46 PM

You could clean the IAC, but it might be normal. This fuel system is designed to hold rpms when shifting. When you shift into N going downhill, the ECU sees a VSS signal, and maintains a higher rpm because that helps you shift into gears. Once you stop, it waits a few, then drops the idle to N speed.

Letting off the gas going downhill--- um, the idle will stay up then because the car is in gear. Fuel is cut off, but the engine will spin at the same speed because the wheels are turning the engine.

whynotthinkwhynot 10-07-2012 12:49 PM

I'd also consider an A/F reset: Remove negative battery terminal for 10 mins or so, then reconnect. Start engine, do not touch accelerator. Engine idle will be slightly high, and will fluctuate. The ECU will time a test 5 minutes after the engine drops out of cold-start mode. What you'll see is idle up to about 1500, then drop and stay around 1000 rpm. At the end of the test, idle will drop to 700. Now the A/F is set. Wait about 6-7 mins, and listen or check the tach for the drop.

Common vacuum leaks include the PCV vacuum line. You should be able to find a ton of information on that on here because it causes many problems in older Zetecs. Depending on how it goes bad it can cause a high or low idle.

perkgana 10-07-2012 02:02 PM

I never said I was going downhill. This happens on a flat road.

I did an experiment yesterday. While driving in 3rd gear at about 3k rpms I let off the throttle and shifted to neutral. The engine stayed at 3000 rpms for a LONG time while I coasted down the road. Finally after about a block coasting I braked and once I got to about under 10 mph the rpms started dropping to about 1200.Weird!

I've read something about "Throttle body resonance" which seemed to be a problem and caused a recall.

sailor 10-07-2012 02:10 PM

Commented on your other posting...

perkgana 10-07-2012 02:12 PM

Cool! sorry was my first post and I guess I screwed it up! hahaha Posted twice I guess


All times are GMT -5. The time now is 11:41 AM.