Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   changed tps now car has horrible miss....help?? (http://www.focusfanatics.com/forum/showthread.php?t=299088)

smurf91 10-04-2012 11:29 PM

changed tps now car has horrible miss....help??
 
I just changed the tps on my 2000 Ford Focus SE and now my car has a horrible miss. Changed the plugs and wires to see if that helped but it didn't. Car chugs under a heavy load and tries to stall when stopped. Wondering if the tps did not seal and could be causing a vac leak. It didn't chug until I changed the tps. Mileage on the motor is 30,xxxx and mileage on the car is 109,xxx. It is the 2.0 duel overhead engine. Any other ideas??

iminhell 10-05-2012 01:15 AM

The O-ring is to keep debris away from the bearing on the throttle shaft. Not to seal out an air leak.

The TPS is probably bad.
There is a good portion of people who've found a loophole in returning electronic parts. Clean up the broken old part, put it in the box of the new one and return it to the store claiming it wasn't the correct part. Next guy in line gets a broken used part. Yay.

smurf91 10-05-2012 01:39 AM

Thanks for the quick reply. I have 3 tps and thankfully this is an easy job. Ill get on it first thing in the morn. Will post results.

whynotthinkwhynot 10-05-2012 06:00 AM

Did you install it correctly? The TPS must be slightly tilted towards the air intake in order to seat on the shaft properly- you will have to rotate it in order to make the screw holes line up. If you do not install it correctly, it will lead to problems like this or KO the whole TPS.

smurf91 10-05-2012 09:29 PM

Well its fixed,for now. Turns out I had a bad coil. I got a msd coil,ford racing wires,k&n air filter today. it had a #4 missfire. I still have a little slop in the trans but I'm going to change the fluid and filter next week. Just wondering what is the best fluid to use? Only 109,000 on the car. After the fluid change I plan on getting a cat back system installed. Looking for best mpg. Also have a bad vibration. Changed transmission mount but didn't help. Thinking motor mount but it has no play. Could the dog bone mount under the car cause the vibration. Transmission mount is motorcraft. I have some work in line but this is a fun car to work on!!


All times are GMT -5. The time now is 02:04 PM.