Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   P0171 Help (http://www.focusfanatics.com/forum/showthread.php?t=298760)

K_Weeve 09-30-2012 10:37 AM

P0171 Help
 
Hey guys and gals. I've got a P0171 code from my 2006 2.0l ZX4. It will occassionaly run rough and loop when idling. Once I give it some gas, it runs fine. I've tried looking for a vacuum leak visually and with the carb cleaner trick with no luck. After searching the net, I came across an post about the IAC valve and thought it might be it. I took it off and cleaned it (even though it wasn't really dirty), but it didn't fix it. I played with it some more and noticed that while it was running rough, I could unplug the IAC and the car started running fine. Plug it back in and a second or 2 later it acted up again. I replaced it but still have the problem. Where should I look next?

stromberg2 09-30-2012 04:18 PM

Hope somebody knows because my svt acts up, too.

Stromberg2

BC_ZX3 09-30-2012 07:29 PM

P0171s are usually a lean condition caused by a vacuum leak of some sort after the MAF. On the Duratec motor, the PCV line is particularly difficult to inspect and replace, iirc. There is a thread on FF with pictures. Edit: thread here

DTC definition from Ford:

P0171 - System too lean (Bank 1) The Adaptive Fuel Strategy continuously monitors fuel delivery hardware. The test fails when the adaptive fuel tables reach a rich calibrated limit.

For lean and rich DTCs:

Fuel system:
Excessive fuel pressure.
Leaking/contaminated fuel injectors.
Leaking fuel pressure regulator.
Low fuel pressure or running out of fuel.
Vapor recovery system.

Induction system:
Air leaks after the MAF.
Vacuum Leaks.
PCV system.
Improperly seated engine oil dipstick.

EGR system:
Leaking gasket.
Stuck EGR valve.
Leaking diaphragm or EVR.

Base Engine:
Oil overfill.
Cam timing.
Cylinder compression.
Exhaust leaks before or near the HO2Ss.

A SHRTFT-1,2 PID value between -25% to +35% and a LONGFT-1,2 PID value between -35% to +35% is acceptable. Reading beyond these values indicate a failure.

K_Weeve 09-30-2012 09:12 PM

Thanks BC. I suspected that there was something hidden behind the intake. I'll likely have to wait until next weekend to take a look at this again, but thanks for the insight.

zx003 10-02-2012 03:03 PM

I solved my P0171 issue by replacing the PCV hose. Try that first. It's not expensive and easy to do. It also solved my floating rpm (not the hanging one), meaning, when you rev the engine to 2.5k, it stays there for a second or two until it goes down.... to a hanging rpm where it stays at 1.5k, then another second or two to go down to regular idle.

[?|]

K_Weeve 10-03-2012 02:38 PM

Thanks zx003. Thats what I was going to check next. Funny thing that you mention the rpm. I have the same issue. I wasn't sure if it was something I didn't notice before because it is my wife's car and I don't drive it too much. Sound like we've got it pinpointed. I'll be addressing it on the weekend. I'll let you know what I find.

K_Weeve 10-08-2012 05:24 PM

Thanks all for your help. It was the PCV hose. I noticed that it was extremely close to the block, so I took an extra piece of hose and wrapped it around the PCV hose to help protect it from the heat. Only problem I ran into was I broke a nipple off the intake manifold. I tried to get one at a junk yard, but ended up drilling it out and using epoxy to glue some tubing in its place. Fixed on a budget ;P
Thanks again everyone.
Ken


All times are GMT -5. The time now is 05:17 PM.


http://www.focusfanatics.com/aboutus/copyright.asp