Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Forced Induction (http://www.focusfanatics.com/forum/forumdisplay.php?f=44)
-   -   Overheating issues (http://www.focusfanatics.com/forum/showthread.php?t=297886)

svtf1417 09-17-2012 08:28 PM

Overheating issues
 
I have my own ideas on whats going on but I figure Id ask for everyone elses feedback.

Has anyone had problems keeping their oil cool or their water temp cool on a 90+ degree day even on the highway? Are you using the stock oil cooler? Aftermarket oil cooler? Do you have one of the 2 fans running constantly or when does your low speed fan turn on? What weight oil are you using? My temp gauge will go up to about 205, the fan/s turn on and drop it abruptly down to ~190. But the very instant the fan turns off, the temp starts climbing right back up again. Keep in mind this is cruising at 70-75 on the highway. Also when my car gets really hot like this my oil pressure drops SIGNIFICANTLY, and Im pretty sure its now caused bottom end damage.

School has started already, and I dont care to mess with my car until spring time, but it would be nice to hear if others have had this problem, or what you do to combat the terrible enemy known as heat.

ZXthrizzle05 09-17-2012 09:21 PM

A tune will make ur fans run on different temp times.

Mother Focus 09-17-2012 10:23 PM

How old is your rad?

svtf1417 09-17-2012 10:29 PM

pretty sure its the stock radiator

sporadic 09-18-2012 06:49 AM

205 isn't overheating, and having lower oil pressure after warmup is normal.
When you come to a stop where does the temperature hit? If you are actually overheating then when the car stops with the engine still running the temps will continue to climb until something pops.

svtf1417 09-18-2012 08:10 AM

I know its not physically overheating. When I stop or drive through the city it gets worse and it heats up faster after the fans shut off.
I was cruising on the highway like I said previously at 70-75 and my oil pressure slowly started dropping, and got all the way to 30psi. I slowed down and turned my heat on full blast to help cool it and my oil pressure went up 2-4 psi. Where I was they have stop lights on the highway, and I got stopped at one close to my girlfriends house and my oil pressure was all the way down to 10psi. I should have stopped right there, but I limped it through town (max speed is only 25) for another few minutes to her house and when I pulled in i could hear a faint knocking noise.

I shut it off and let it cool off completely. Went outside and started it and it makes a very noticeable knocking noise for a split second until it build oil pressure which was normal for it being cold and it goes away. As the car warms up just sitting idling, at about 150-160 you can hear that faint knocking noise starting again. If I blip the throttle its more noticeable and its not the lifters.

Im not at all happy that it only lasted a season, and failed under normal driving conditions of all things. I just figured you all might have had some insight on how to keep this from happening again

1turbofocus 09-20-2012 07:54 PM

I would have the Raid checked , are you SURE your thurmostat is a 180 did you confirm this by looking at the stamp 180 in the bottom

I use 20-50 oil in anything I do performance

Tom

svtf1417 09-21-2012 08:22 AM

Yup im positive. Even on a cooler night cruising down the highway it wouldnt reach above 182

1turbofocus 09-21-2012 03:09 PM

Then I would check the raid , flush and clean it and go from there , a datalog of a cruise doing this would also be nice

Tom

svtf1417 09-21-2012 06:48 PM

Do you use 20-50 on engines that have stock clearances?


All times are GMT -5. The time now is 05:24 PM.


http://www.focusfanatics.com/aboutus/copyright.asp