Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   MK1 Focus (http://www.focusfanatics.com/forum/forumdisplay.php?f=45)
-   -   2002 forus 2.0 running issues? (http://www.focusfanatics.com/forum/showthread.php?t=297826)

bearster18 09-17-2012 08:47 AM

2002 forus 2.0 running issues?
 
i have a 2002 ford focus with the 2.0 split port engine that was rrepalced with a ford reman engine 20k miles ago. I dont know why it was replaced just know that i have the reciepts and warranty info from the previous owner. More than likely for the dropped valve issue.

NOW! This thing is running rough at idle. It'll sit at idle and the vehicle will like try to cut out slightly and sometimes will just up and die. Its rare but it will do that sometimes. Also thing is getting horrible gas mileage as well. Like 18 mpgs which i don't feel is adequate from what i've read about online. To add to the list of issues or better clarify this. Also at low speed and light throttle the vehicle will kinda surge and pulsate. I've checked the computer for any stored codes but not a single code stored.

I've got new plugs, wires, alternator(oem), front o2 sensor, ran fuel injector cleaner (lucas), cleaned the maf , and cleaned TPS plug.

Still yet its running the same way. Anyone have any ideas or suggestions for me to try?

GO.army.1969 09-18-2012 06:50 AM

My not be but thats what happen to mine before it dropped. It did that for about 10k and then BOOM


All times are GMT -5. The time now is 06:36 PM.