Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   Electrical issue I think (http://www.focusfanatics.com/forum/showthread.php?t=297782)

Lecky 09-16-2012 02:43 PM

Electrical issue I think
 
Having trouble with my Electrics in need of abit of help.

First of all I've checked all the fuses in both boxes on my focus including the fuse behind the fuse box hidden behind the glove box.

My Stereo wont even turn on but I dont know if it a broken stereo as I have not long had the car or whether it is maybe a fault in the wiring somewhere on the car that could be causing it, also checked the fuses.

When I turn the car headlights on in the car I notice everything is lit up barring my drivers side window controls. although this is not a major issue im just wondering why its doing this as Im also having trouble with the central locking and Im not sure if its all connected.

The central locking I can unlock the doors with the fob and open my boot with the fob but cant lock the doors with fob I have to use the key.

Ive noticed when I start my car that the button next to rear window heater button. The internal air circulation one always switches on on startup Im not sure if this is normal? But when its wet sometimes it wont switch on and wont work at all.

A couple of times when the car is turning on full lock ive had the issue of the car just stopping with the engine still running and the steering really stiff as if there is no power steering.

I know there is a hell of a lot of information here my guess is I have a dodgy wire somewhere that maybe stripped a little or loose? Any help with any of this would be greatly appreciated. Anything I can do myself is alot better than the garage charging me to fix everything.

Cheers guys

whynotthinkwhynot 09-16-2012 05:44 PM

Well we don't have wiring diagrams for UK Foci, and things are likely to be different between RHD and LHD. I can give you this advice though, when I have problems with several seemingly unrelated electrical systems, the problem is usually earthing somewhere. You have to check all the negative connections- especially at the battery.

Lecky 09-17-2012 02:25 AM

Cheers mate thanks for the advice. Will get under the bonnet today and look for any loose wires. Any advice the best areas to look through experience ie. any problem areas that come about with older foci.

Cheers

GreySkorpion 09-17-2012 07:15 AM

Check the grounds under the hood and behind both driver and passenger kick panels, there were 3 total on my car behind the kick panels.

Lecky 02-26-2013 11:51 AM

I know this was a long time ago now but have fixed most of the issues.

1: Plugged in a after market stereo and it worked fine so was probably a dud stereo

2: Tried a multimeter on the lock button micro switch in the fob and found there is no continuity along the switch so have found some new switches on ebay so must be a common fault.

3: The fault where the speedo hit zero and lost power steering was a speedo sensor fault which was fixed at the garage.

yet to have a look at the windows switch lights on the door but noticed that they work more in extreme cold weather so not sure what that is lol.

Just thought I'd update my findings incase this is of any help to anybody in the future


All times are GMT -5. The time now is 01:49 PM.


http://www.focusfanatics.com/aboutus/copyright.asp