Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   MK1 Focus (http://www.focusfanatics.com/forum/forumdisplay.php?f=45)
-   -   Brand new A/C short cycling already... (http://www.focusfanatics.com/forum/showthread.php?t=297307)

n00btard 09-09-2012 07:26 PM

Brand new A/C short cycling already...
 
So.....

I've just put in a new A/C system and it's short cycling two months later --WTF? On top of that when the clutch kicks on it tugs on the belt so hard that I can feel the loss of power to the wheels --I mean a noticable jerk. When I'm idling @1000RPMs (custom tune setting) the A/C clutch engaging pulls my engine down to 800RPMs and it's noticably taxing the engine.

I did this A/C system at the same time as my timing belt, serpintine belt, alternator upgrade, water pump and some other routine maitenence. The system is holding vacuum and it's still cold.......what the heck is STILL wrong?

elsolo 09-09-2012 10:29 PM

If it were slightly overcharged, it would have symptoms similar to what you describe.
-frequently cycling off due to overpressure switch
-increased load on compressor
-still cools OK

n00btard 09-09-2012 11:44 PM

Quote:

Originally Posted by elsolo (Post 4345029)
If it were slightly overcharged, it would have symptoms similar to what you describe.
-frequently cycling off due to overpressure switch
-increased load on compressor
-still cools OK

I only have a low pressure side gauge. Do I need to get another to check if that's what's happening?

The other thing is that I can FEEL the the loss of power when clutch for the compressor engages --even in 5th gear. I thought that wasn't supposed to happen anymore (all my cars have been classics before now)


All times are GMT -5. The time now is 11:42 AM.


http://www.focusfanatics.com/aboutus/copyright.asp