Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   SVT Performance (2002-2004) (http://www.focusfanatics.com/forum/forumdisplay.php?f=40)
-   -   So about them steeda motor mounts... (http://www.focusfanatics.com/forum/showthread.php?t=296058)

wesley4x4 08-24-2012 01:24 PM

So about them steeda motor mounts...
 
Hey guys look what I did!!!!!http://img.tapatalk.com/c6e4c99b-c6fd-5c35.jpg
http://img.tapatalk.com/c6e4c99b-c70a-2cb5.jpghttp://img.tapatalk.com/c6e4c99b-c715-9364.jpg

svtmichael 08-24-2012 01:50 PM

SO MUCH FAIL. I was thinking about buying some too...

TommyTooHi 08-24-2012 02:04 PM

The CFM mount doesn't have all the flubber hanging out the sides... looks like that's what failed.

Still, congrats, how long was the air hang time on that jump - did you get your pilot's license? hahahahahahaaa

http://focus.c-f-m.com/cfmlowerengin...0-10focus.aspx

tj@steeda 08-24-2012 02:44 PM

Shoot me an email at tim@steeda.com so that we can analyze the situation and see exactly what happened?

Do you drag race the car?
How many miles do you have on the car?
Did you purchase the product directly?

Lets try to determine why this failure occurred.

Best Regards,

TJ

ViperThreat 08-24-2012 03:07 PM

I did the same thing to the inserts i bought at FSWerks..

Then again i was launching hard at the dragstrip lol

1turbofocus 08-24-2012 04:07 PM

Quote:

Originally Posted by tj@steeda (Post 4320287)
Shoot me an email at tim@steeda.com so that we can analyze the situation and see exactly what happened?

Do you drag race the car?
How many miles do you have on the car?
Did you purchase the product directly?

Lets try to determine why this failure occurred.

Best Regards,

TJ

TJ , just curious , these bushings are supose to be better then the stock one , are they not to be drag raced ? does 100,000 miles hurt them ? I have never seen a stock mount do what these mounts are doing ???

Tom

iminhell 08-24-2012 05:27 PM

I split a VF mount the same way.
At the track I got too much wheel hop and I felt something give. It was the bushing.

My theory on why/how they split is engine misalignment (which I'd feel confident is the OP's issue noting the off-center nature of the split). Of the few Focus's I've been under with mounts, all of them (mine included) the dogbone doesn't look straight.
In the past what I would do was install the dogbone, then the upper mounts and leave the uppers a little loose. Get in the car and load the engine to center it, rock it back and forth with the trans engaged. That seemed to help, and as a side benefit it reduced the vibration in the car considerably.

The slpit could be from a bad mold, air pockets and such. But I haven't seen hard evidence that the molds are bad yet.

05focusST91 08-24-2012 06:47 PM

So this is making me reconsider poly mounts but then again besides vf i havent seen any other companies making them for us

NJSVTGUY 08-25-2012 04:51 PM

Quote:

Originally Posted by 05focusST91 (Post 4320489)
So this is making me reconsider poly mounts but then again besides vf i havent seen any other companies making them for us

I just buy the poly and press them in the stock bracket, those look uncircumcised.

_Auricom_ 08-25-2012 05:09 PM

I just got mine in from MASSIVE. Purple color Poly mount won't go out on me I'm sure!


All times are GMT -5. The time now is 06:58 PM.


http://www.focusfanatics.com/aboutus/copyright.asp