Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   Wheels & Tires - Sponsored By Tire Rack (http://www.focusfanatics.com/forum/forumdisplay.php?f=50)
-   -   Installed FRPP kit. Now hearing a noise (http://www.focusfanatics.com/forum/showthread.php?t=295820)

RAF_S197 08-21-2012 01:30 PM

Installed FRPP kit. Now hearing a noise
 
Hey guys,
I recently installed the FRPP kit (new) on my 2009 from Tousley Ford.
When I go over bumps I hear a clunk in the front end. I believe it's the springs on the struts making the noise. While installing the FRPP kit I did notice that the top of piece that goes on top of the spring (which is attached to the strut mount) is different than my stock one. Also there is a small thing worn out rubber piece that goes over the top coil of my stock front spring which did not come with the FRPP kit.

Any ideas as to what might be wrong? I'm prett positive I installed everything right.

nov173 08-21-2012 02:12 PM

is your spring sitting in the strut right? is it shifting possibly? or tie rod

RAF_S197 08-21-2012 02:17 PM

I made sure the spring is on the strut right. Unless it could have moved. Not sure on the tie rod but I never had the noise before the FRPP kit. I also replaced the end links thinking that was the problem but it wasn't

nov173 08-21-2012 02:26 PM

ya i don't even know why i typed tie rod... i mean to say end links.. cuz that's usually the issue. I didn't have an issue when i installed mine many moons ago on my old car. do you have an idea where the clunking is coming from? have someone stand outside the car when you go over a bump

RAF_S197 08-28-2012 10:39 PM

Anyone?

RAF_S197 09-01-2012 12:12 AM

Hey guys. I just remembered. The kit didn't come with any front isolators. Could this be the cause?
I re used the stock rear isolators but there's nothing in the front of the new kit to be reused nor with the FRPP kit

billand 09-01-2012 12:36 AM

I would look for new rubber prices between the spring and the strut mount also go back and check your torque specs on all bolts. For recommends changing bolts and hardware every time you remove shocks and struts so that my be why your hearing a noise.

elsolo 09-01-2012 12:00 PM

There are no rubber isolaters in the front.
The pre-assembled SVT struts have nothing but steel springs on steel mounts, and they don't make noise.

Often, it is the top strut mount bearing that makes the clunking noise.

billand 09-01-2012 12:15 PM

Check the strut mount they are open ball bearings and some times the break and the bearing come out

elsolo 09-02-2012 01:47 PM

Quote:

Originally Posted by billand (Post 4331485)
Check the strut mount they are open ball bearings and some times the break and the bearing come out

There are no ball bearings in a stock Ford focus strut mount assembly.

The "bearing" is a plastic flange bushing that goes between the spring retainer plate and the strut mount.


All times are GMT -5. The time now is 10:27 PM.


http://www.focusfanatics.com/aboutus/copyright.asp