Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   2nd time around, need some ideas, SPI will not stay running (http://www.focusfanatics.com/forum/showthread.php?t=295517)

ponddogs 08-17-2012 10:55 AM

2nd time around, need some ideas, SPI will not stay running
 
2003 SPI engine, bought the car with a pining noise when accelerate and wanting to die after the engine warm up, ford house said bad gas, drained fuel tank 3 times, change out filter 3 times and the in-tank fuel pump, change out plugs, wires, coil pack, crank sensor and cam sensor, had the engine cat tested for back pressure, had the fuel injectors checked, getting 35 psi at injector rail, then engine drop number 1 cylinder valve exhaust seat, change out head assy, piston and piston rod, timing belt and engine gasket set, engine would not start, back to ford house, they said engine oil pump is not working, change out pump, oil light now goes out when cranking but when cranking engine it's sound like if the engine timing is too far advance, had the ECM reflashed, rechecked the engine timing belt both dots and key way locations, checked the engine compression 160 160 155 160, change out the throttle body off a running focus, now if you pour some fuel in the throttle body it will start but only stay running if you feather the throttle and the pining noise is back with a miss, no engine codes, any ideas will help

MEJY1988 08-17-2012 11:11 AM

IMO, if you have 35 psi at fuel rail, but need to dump fuel into throttle body to get it started, you either have a clog in the fuel rail, faulty injectors, or the injectors are not firing. You can get noid lights to check the voltage at the injectors. I would start there.

Good luck.

ponddogs 08-18-2012 10:41 AM

Thanks for diffrent starting point, I will order a noid light set today, Question ? what control the engine timing, crank, cam and ECU, since I have change out crank and the cam sensors and had the ECU reflashed would it be worth the money to have another ECU reporgram, because I found out you just can't swap them out

ponddogs 08-19-2012 12:27 PM

got the noid light set today and went out and tested the fuel system, no light when cranking the engine, I even tested the kit on a running focus to see if it was working, also replaced the wire harness from the firewall to the engine, no light, is there a way to test the ECU without taking it to the ford house?

ponddogs 11-18-2012 10:26 AM

it's runs, time to sale it
 
Well after thousands of hours of working on this thing, I finally got it and had to take it to the ford house 5 times, without any luck. took it to the ford house to have a new ECU install, still nothing, they said everything is working the way it's supposed to, but the engine sounded liked it was out of time, well to make a long story short, before I bought the car the owner had the head replaced (didn't know) and they changed out the harmonic balancer with a china replacement, well the timing clods that are press on was not a real tight fit and was moving, did not see this at until I sat a old harmonic balancer on top of the china replacement, it was off almost 45 degrees, put on the old balancer and it started right up, unbelievable

sailor 11-18-2012 01:27 PM

"Unbelievable" seems to cover it....

That's definitely a "New One" for a no start problem...

mikebontoft 11-18-2012 02:35 PM

agh...[facepalm]


All times are GMT -5. The time now is 05:55 AM.


http://www.focusfanatics.com/aboutus/copyright.asp