Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   Car stalling out when coming to a stop. (http://www.focusfanatics.com/forum/showthread.php?t=294145)

thehypeisreal 07-31-2012 06:59 PM

Car stalling out when coming to a stop.
 
I made this in the general tech chat forum but I figured I might as well post it here as well considering its a duratec.... Ok so my car has had issues firing right up for a while now, I was starting to think my fuel pump was going out, but from what little bit I've read on here, this seems to be a common issue. However, that's not main reason why I'm here. A couple weeks ago it started cutting off whenever I would come to a stop(redlight, stop sign, etc.), electronics would surge at an idle(if the car didn't cut off), I would sometimes have to jump it off and my charge light came on. So I took it to a shop and they told me it was the alternator. I decided to replace it myself. I start undoing everything and one of the first things I came across was a broken ground wire(I'm assuming). It comes off the wiring harness that is connected to the fuel rail and bolts to the power steering reservior bracket. So I go to a junkyard, get the wire and swap it out. The charging light went out but all of the other problems still existed. So I take it to a different shop someone reffered me to to get a second opinion and they told me the same thing, alternator. So I went ahead and replaced it, charged my battery back up and now I'm still dealing with the cut off issue. Oh yea, if it helps, before all of this other stuff started happening, whenever I was low on fuel(say 1/8th of a tank or lower) and I would go around a sharp left hand curve or say an on-ramp with some speed the car would act like it was trying to cut out, like it was being starved of fuel.

I also need to note that in addition to the stalling issue, the rpm's are moving around a lot between about 200 and 1k. I have seen a few other threads with this same issue but I honestly dont know where to start to figure out the problem. Fuel filter and spark plugs have both been replaced within the past year. So what should I check next?

thehypeisreal 07-31-2012 07:01 PM

BTW, its for an 05 2.0 5 speed, if that helps

BLÜE_BÄLZ 07-31-2012 07:03 PM

Id start by cleaning your IAC and or MAF.
More than likely that will solve your prob [thumb]

helps in 00-04's may work on your 05

thehypeisreal 07-31-2012 07:15 PM

Ok I kinda know what a MAF is, but whats an IAC?

warneej 08-01-2012 10:05 PM

PCV hose has ripped behind your intake manifold.

/problem.

pureford. 10-25-2012 08:23 PM

Diddo
 
i've been having similar problems with the stalling out at red lights and have been working to fix it. i have the same 2005 zx4 2.0L 5-speed. i put in new spark plugs, fuel filter, and i cleaned all my intake sensors. also have a brand new air filter in my cai.

Jgrove998 10-26-2012 11:09 AM

Quote:

Originally Posted by warneej (Post 4288083)
PCV hose has ripped behind your intake manifold.

/problem.

This^

I don't recall ever hearing of a Duratec Fuel Pump failing since I bought my first '05 SE back in 2007.

Fuel filter may need changed as well; only a couple bucks and a hour under the car.

thehypeisreal 10-26-2012 10:19 PM

Ended up being a dirty MAF for me. Cleaned it with maf cleaner, reset the mixture. Problem solved.


All times are GMT -5. The time now is 08:21 PM.