Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   ABS Light (http://www.focusfanatics.com/forum/showthread.php?t=291798)

rbrad6937 07-03-2012 05:06 AM

ABS Light
 
2006 ZX4, SES, 5spd,
My abs light has been on constantly. I recently checked it with a abs capable code reader and a C1145 code came up. This code is for a failure to the right front wheel speed sensor. I replaced the sensor last night and drove to work this morning (35 miles) but the light will not go out. Do I have to clear the code with the reader or will it go out on its own? Is there something I am missing?

UPDATE: I just tried to clear the code with the reader but the light and code are still there.

Robert

rbrad6937 07-04-2012 06:35 AM

I keep reading that this is a common problem with the Focus but I get no replies on what the possible fixes are. Could this be the ABS control module that is causing the one error to the right front wheel sensor? Does anyone know how to trace the wires from the wheel speed sensor back to the control module? Schematics? I only have until the end of the month to get an inspection sticker and I don't want to take it to the dealer if I don't have to.

Thanks in advance

Robert

239rsw 07-04-2012 07:16 AM

Inspection Sticker. If it is emission, nothing to worry about. ABS is not emission related. I passed emission twice with the ABS on. I haven't fixed mine yet - both front and left rear wheels. It came out when the when the wheel bearings were replaced incorrectly.

rbrad6937 07-04-2012 07:27 AM

I live in New Hampshire and the ABS light is on and I cannot clear the C1145 code after replacing the right front wheel speed sensor. In New Hampshire this is considered a safety issue which will cause a failed inspection.

239rsw 07-05-2012 06:16 AM

What happened to the live free die free? Kidding aside, don't they sell cars without ABS nowadays in NH?

rbrad6937 07-09-2012 05:08 AM

Problem fixed. The steps below outline what I had to do for the repair.

1. Removed battery and battery holder from car.

2. Unplugged connector from ABS control Module.

3. Unplugged connector from right front Wheel Speed Sensor.

3. Performed a continuity check between pins 5 + 6 on the ABS control module connector and the pins on the disconnected right front wheel speed sensor.

The continuity from ABS module Pin 6 to the wheel speed sensor connector was good but I found an open condition at pin 5. I did an inspection of the pins and connector at the wheel and it all looked like new. I started to pull the wire harness out of the plastic outer protective jacket at the right wheel going towards the ABS control module. About 12 inches in I found a broken wire. I soldered the wire back together, applied sleeving, plugged it all back in and took the car for a test drive. After going about 100 feet the ABS light finally went out. I am totally stumped as to why the wire broke where it did. It was in an area where there should be no flexing. It may have been a problem that started from the previous owner. It took me about 2 hours to finally find the problem, fix it, and get it back together. Hope this helps someone else with similar problems.

carlos1984 01-29-2013 10:31 PM

I am having abs light after garage replace bearing ,cylinder, sensor and abs ring on my right rear, would it be possible to let me know where the abs control module is located, is the wheel speed sensor the same as abs sensor if so where is it located and do i need to remove the wheel?

Sorry for all the questions, im am just hoping to fix this issue myself,as I feel I keep being screwed over by garages.Plus i dont have the money to get this problem repaired.


All times are GMT -5. The time now is 03:24 PM.


http://www.focusfanatics.com/aboutus/copyright.asp