Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Forced Induction (http://www.focusfanatics.com/forum/forumdisplay.php?f=44)
-   -   Idle issues with pwsc and fc tb (http://www.focusfanatics.com/forum/showthread.php?t=287375)

Theaadman23 05-09-2012 03:47 PM

Idle issues with pwsc and fc tb
 
Alright so the other day I finally put in the fc tb that I have had for a while on to the pwsc. My bbk tb was causing stalling issues. So I put in the fc tb and I had a issue first with the spring it was sticking out past the bottom of the tb so I figured this was normal and installed it by drilling just a tiny hole in the pwsc and it was outside where the gasket sits so I know it's not causing a vacuum leak. Well when I go to turn the car on the idle is around 1500 to 1900 even after warming up. I look as the idle screw and turn it lower but the metal plate that should hit it doesn't go any further. I don't know if this is normal or not. And way I found out if I turn the ac on the idle goes down to 900 to 1000 but jumps for like 2 or 3 seconds drops back down and jumps back up and down again and keeps this up when ever I am at a stop. So first the three holes in the tb are they all supposed to have their own hole in the gasket or can it be one hole. Pretty sure that I put the tps on the right spot so I have no idea what to check next

1turbofocus 05-09-2012 10:16 PM

A good tune will help with those issues , what tune do you have ?

To set the idle , unhook your idle air controle valve , car should die , restart the car and set the idle screw to 750 rpm then plug in the idle aire controle valve , idle set properly

Tom

Theaadman23 05-10-2012 08:08 AM

Ok when I adjust the screw back off to lower the plate that it should touch does not go down to it. And I am on the stock pwsc tune

1turbofocus 05-10-2012 10:01 AM

Did you do the idle screw the way I stated above ? that is the only correct way to adjust the idle
You may have a Vac leak

A datalog would go a long way to help with your problem

The Ford Racing tune for the jrsc and the PW tune for the PW is only made for an all stock car with just the SC added any other mods added will change the tune

I hope you have at least a wide band air fuel gauge and are watching the AF , the PW tunes blew up a LOT of engines

Tom

Theaadman23 05-10-2012 03:25 PM

Ok so I tried unplugging the iac valve but the car just just kept running like I didn't do anything. Idle is still in the 1500 rpm range

The tps is correct if it's in the 00-02 screw holes right?

1turbofocus 05-10-2012 04:19 PM

You unplugged the IACV , car didnt die? should of , then you tried adjusting the idle screw OUT to see if the idle would lower and it didnt ?

Sounds like a Vac leak or wrong / bad Idle Air Control Valve , Vac leak would be my first choice

Tom

Theaadman23 05-10-2012 04:51 PM

Ok you think the gasket from the bbk tb would not make a good seal with the fc tb? Tomorrow I am going to put the bbk back in and see if it is the iac valve

Theaadman23 05-12-2012 07:17 PM

So I put the bbk tb back on and I still have a ideals with the idle. I tried unplugging the iac valve but same thing stayed running but when I revved the engine the Roma when to 3k and stayed there so I shut off the car. Should I go ahead and replace the tps or iac valve? Cause I figured it's one of them or both. Also my one rubber oil line burst and I have no idea what kind of rubber hose to buy. Is it just high temp rubber hose?


All times are GMT -5. The time now is 07:45 AM.


http://www.focusfanatics.com/aboutus/copyright.asp