Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   Focus SVT (http://www.focusfanatics.com/forum/forumdisplay.php?f=65)
-   -   How To: Use the SVT Gauge Cluster on a non-SVT Focus (http://www.focusfanatics.com/forum/showthread.php?t=261392)

bay_wolf 06-23-2011 01:42 PM

How To: Use the SVT Gauge Cluster on a non-SVT Focus
 
*Click Pictures to Enlarge*

Background: There is a lot of misconceptions as to the compatibility of gauge clusters being swapped. Basically, you can swap any Zetec cluster into another, this holds true for the SVT cluster as I'm going to show you. For other engines, I believe the plug is different so I don't think they will work with each other.


Objective: Get the SVT Gauge Cluster to fully work in a non-SVT car, this means having the AUX gauges work and the stock EL backlighting without purchasing an extra inverter.


Two ways to accomplish it:

1) You can do the splices directly into your harness. I found this would be extremely difficult due to the cramped space and the potential to ruin your wiring harness.

2) You can do it how I did it and create an adapter to plug the cluster plug from your car into and the SVT cluster plug into the same adapter. This was very difficult also but a safer way. I feel this would be the best way to do this so that it is 100% reversible if need be.


Materials Needed:
*NOTE: there are two ways to do this so the list below is what I used to create the adapter.*

old gauge cluster (for the connector)
soldering iron & solder
desoldering iron
SVT gauge cluster & aux gauges
electrical tape
hot glue
22 gauge wire
digital multimeter (to check connections and pin routes)
the aux gauge plug and main cluster plug
a printed circuit board or project board from radioshack


Finally the steps:

1) Look over these wiring diagrams as you'll need to know where the pins are on the connectors.

http://i.imgur.com/MOumAs.jpg http://i.imgur.com/k8svDs.jpg
http://i.imgur.com/yFdrCs.jpg


2) Desolder the connector off of the old broke gauge cluster (only if it's a broken one or one you don't care about). Mine came from another SVT cluster that an ebay seller broke trying to fix the mileage.

http://i.imgur.com/Ntwpws.jpg http://i.imgur.com/Egv1ns.jpg
http://i.imgur.com/sWdcPs.jpg http://i.imgur.com/xKdv0s.jpg

3) Time to start splicing all the wires together (you may have to extend some of the wires length by soldering more wire as needed). Below you'll find the pins that need to be connected from the aux connector to the main cluster connector:

Pins 1 and 9 from the aux connector connects to the 2 wires on the top of the main cluster for illumination. Just match the colors up for this.

Aux Cluster Pin -----> Main Cluster Pin
Pin 4 -----> Pin 16 [Voltage supplied in Start and Run ]
Pin 5 -----> Pin 19 [Oil pressure switch, input ]
Pin 6 -----> Pin 13 [Standard Corporate Protocol (SCP) data +]
Pin 7 -----> Pin 26 [Standard Corporate Protocol (SCP) data -]
Pin 8 -----> Pin 14 [Battery voltage, hot at all times]
Pin 12 ----> Pin 4 [Speed control indicator, control ]
Pin 14 ----> Pin 10 [Battery voltage, hot in Run and Acc only]
Pin 15 ----> Pin 3 [Illumination dimmer switch output]
Pin 16 ----> Pin 2 [Ground]

Pins 2, 3, 10, 11, 13 are not used on the aux connector.

I complete all the splicing by just soldering the wires together then using some heat shrink tubing to seal it up.

4) Once I completed soldering all of those up it's time to solder those wires onto the connector. I personally bought a project board from radioshack but wish I could/would have taken the time to come up with less of a ghetto solution as it was pretty difficult to do this. Here are some pictures of the connector after I had soldered it all together and added some hot glue holding it all together better:
http://i.imgur.com/Wc1dqs.jpg http://i.imgur.com/lqWSws.jpg

I then wrapped it up in electrical tape just to be sure. So, here are pictures of the completed adapter:
http://i.imgur.com/NhhEJs.jpg http://i.imgur.com/KyrE3s.jpg http://i.imgur.com/YRRdJs.jpg
http://i.imgur.com/Z4sXFl.jpg

Result:
YouTube Video
ERROR: If you can see this, then YouTube is down or you don't have Flash installed.
YouTube Video
ERROR: If you can see this, then YouTube is down or you don't have Flash installed.

Everything works except the oil temperature but there's nothing I can do about that. You'll also need to get the cluster reprogrammed for your car or else the ABS and brake lights will be on.

bay_wolf 06-23-2011 01:42 PM

Reserved for updates in the future. Also, ask any questions and I'll try to clarify the how to.

bay_wolf 10-10-2011 07:15 PM

Just wanted to put an update that my RadioShack project board ended up not working out too well so I picked up some jumper wires to plug onto the connector and wired it up again. I'll get some pictures of the new setup sometime soon. I also have a new modification to the SVT gauges that I'm installing before long.

Ayellowcow 02-17-2012 02:49 PM

Will this work on a SPI Focus?

mitisangel90 12-07-2012 04:38 AM

Ok i just did this to my car and it Worked but when Im driving a little light coming on on the oil gauge that looks like a tach but when I shop it turns off do any of yours? Or do you know What Thats for thanks


All times are GMT -5. The time now is 08:56 AM.


http://www.focusfanatics.com/aboutus/copyright.asp