Ford Focus Forum, Ford Focus ST Forum

Ford Focus Forum, Ford Focus ST Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   2003 cruise control shuts off (http://www.focusfanatics.com/forum/showthread.php?t=253080)

stainlessguy 03-14-2011 06:43 PM

2003 cruise control shuts off
 
Hi everyone. I just found your forum while searching for some answers on my new Focus, hope your able to help. I just bought a 2003 focus on saturday and today on my way to work the cruise control kept shutting off. I would hit the set/resume button and it would work again for about a minute. after it happened about 5 times I just gave up on using it. On one occasion it accelerated itself about 1-2 MPH and then back down....then accelerate.....then back down. It did this about 5 times and I shut it off.

Any ideas what might be causing this issue? Thanks for any help you can provide.

Jon

DrkKnight614 03-14-2011 06:52 PM

Posted via FF Mobile Are you hitting the brakes while using it at all? Also when it accelerates and deccelerates are you ecountering hills? Other then that either it could be a faulty fuse or something deeper. Idk what else it could be.

stainlessguy 03-14-2011 06:59 PM

not hitting the brakes, but thats what it is acting like. No hills either. I actually bought this car from my dad and he had been having the same problem over the past few months

DrkKnight614 03-14-2011 07:10 PM

Posted via FF Mobile Check the fuse, if not, idk I guess bring it to ford and ask them about it. Arent you stull under warranty? You should be right?, bring it to them and have them fix it, thats what warrantys are for.

stainlessguy 03-14-2011 07:13 PM

no warranty, its a 2003 with 120,000 miles on it. Ill check the fuse though.

checked the fuse and its fine.

Justin svt 03-14-2011 07:42 PM

maybe a tps or a speed sensor? or faulty switch one the brake

DrkKnight614 03-15-2011 01:17 PM

Quote:

Originally Posted by stainlessguy (Post 3593242)
no warranty, its a 2003 with 120,000 miles on it. Ill check the fuse though.

checked the fuse and its fine.



Posted via FF Mobile Ahh thought this said 2009 focus.

6SPD_soul 03-15-2011 04:09 PM

How to diagnose cruise control problems.
 
I just had some issues with my CC and have sorted that out, but I found there is a really slick self diagnostic procedure for the cruise control. You don't need a diagnostic scanner to do this either, just the car. From what you describe I think the cruise control servo (motor with a spool of cable that controls the throttle body for CC) is bad, but this test will tell you for sure where the problem lies. This self diagnostic test will work on all Foci from 00-05, in addition to many other Ford models in those years.

The test is basically this: you're going to be turning the ignition key on and off repeatedly and then hitting the cruise control buttons quickly in a specific sequence, and then the cruise control light will blink repeatedly, and the number of blinks tells you where the fault is. It's easy to do once you get it sorted in your head and you won't mess anything up if you don't get it right the first time.

If it's a manual, don't depress the clutch. If it's an automatic leave it in park. First, turn the ignition to the accessory/run position but don't start it. Press and hold the CC off switch and then repeatedly turn the ignition from run to off and back to run again, you should do this 3 or 4 times. End this sequence with the ignition in the run position and then let go of the off switch, and you should see your CC light blink once, which means it's ready to run the self diagnostic. If it flashes 5 times at this point then it's a faulty speed control module, which is that servo I mentioned above. Quickly after the light blinks (like a second after), you then need to hit the other cruise control buttons in this order, and you will need to hit them fairly quickly for the test to proceed:

1. On
2. Resume
3. Coast
4. Set/accel

The CC light should blink once after each button you hit. Kind of take your time hitting the buttons and it's easier to keep track of the flashes, which is important at the end because you need to count the number of flashes that come after you hit "set". There won't be an immediate flash after you hit "set", there will be a slight delay, and then will come another short series of flashes. This next part is all verbatim (except for the parenthesis) from the Ford guide I'm translating here.

0 Flashes (no flash after last button is pushed): suspect circuitry or speed control steering wheel switches.
1 Flash: Static test passed (cruise control should work)
2 Flashes: BPP (brake pedal position) switch is damaged, circuit is damaged, or the brake or clutch pedal was applied during test.
3 Flashes: Brake deactivation switch is open or circuit is damaged.
4 Flashes: Indicates the speed signal circuit is open or damaged (wheel speed sensors, ETC)
5 Flashes: Suspect circuitry or module.

So I guess try to run the test. It's pretty quick and easy once your thumbs get the button sequence down. Then you should at least have a better idea where the problem is coming from. Post back here with results, I'm curious where the problem is for you. Mine was the brake deactivation switch which I'm putting in soon.

BC_ZX3 03-15-2011 09:32 PM

^ This post should be stickied.

mikeeshaq 03-15-2011 11:34 PM

BC_ZX3 is RIGHT
STICKY this post!


All times are GMT -5. The time now is 10:20 AM.