Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   SVT Performance (2002-2004) (http://www.focusfanatics.com/forum/forumdisplay.php?f=40)
-   -   HOW TO: IMRC Removal and Repair (http://www.focusfanatics.com/forum/showthread.php?t=222180)

SVT_ME 01-26-2010 07:09 PM

HOW TO: IMRC Removal and Repair
 
First off, credit for this idea goes to an older thread which now seems to be gone. I'm just going into slightly more detail.


This problem is very common, and I suspect 80% of SVT owners need not replace the IMRC but simply clean the internal contacts.


So, do you have this problem? If you answer "no" to the following, it is 90% likely this procedure will work for you:

1) Is my cable broken?
2) Is my lever broken?

What you need:

1/4in ratchet with 8mm & 10mm sockets
Phillips screw driver #1 & #2
Soldering Iron
Thermal paste
RTV



Ok, lets begin.


First, remove the drivers side headlamp, battery, battery tray, and airbox/uper half of CAI/SRI:

http://i290.photobucket.com/albums/l...IMG_2167-1.jpg

http://i290.photobucket.com/albums/l...E/IMG_2168.jpg


You see that the IMRC is located behind the headlamp.

Now, before unbolting the IMRC box, disconnect the cable from the lever. This is done by (with one hand) roatating the lever towards you, while grasping the end of the cable and sliding it off of the post.


http://i290.photobucket.com/albums/l...E/IMG_2150.jpg

http://i290.photobucket.com/albums/l...E/IMG_2152.jpg


Now, unbolt the box and remove it while snaking the cable out along the path shown.

http://i290.photobucket.com/albums/l...E/IMG_2169.jpg

Ok, the hard part is done [thumb]

Next, take the IMRC to your bench to begin disassembly.

http://i290.photobucket.com/albums/l...IMG_2154-1.jpg

First, remove screws securing cover. Then using a straight razor blade cut around the seam to free the RTV.

http://i290.photobucket.com/albums/l...E/IMG_2166.jpg

Now that the unit is open, remove the screws as shown, and desolder the power wires and connector pins.

http://i290.photobucket.com/albums/l...E/IMG_2148.jpg

Remove PCB, and this is what you have.

http://i290.photobucket.com/albums/l...E/IMG_2155.jpg

http://i290.photobucket.com/albums/l...E/IMG_2156.jpg


At this point you will notice, there is not much to this box. Notice the gears are made of metal, thus the odds they will ever strip is very slim. The electrical circuit is very simple as well, and failure of these components under normal operation is slim to none. The motor is nothing more than a glorified coil, and under normal operation coils are basically indestructable.

Leaving us with the true weak point of this unit... the contact [smackbum] Which is the copper strip with a nickel plated contact shown in the above picture.

Now, to remedy the dreaded P1518, we must burnish (clean) said contact.

Notice the grey color. This is not very condusive to conduction. [idea]

http://i290.photobucket.com/albums/l...E/IMG_2159.jpg

http://i290.photobucket.com/albums/l...E/IMG_2160.jpg


Using a piece of fine grit sand paper (paper), or a fine nail file (file), press down gently on the copper strip (DO NOT BEND COPPER STRIP),

Insert paper/file, release copper strip and pull paper/file out. DO NOT MOVE BACK AND FORTH, SIMPLY PULL.

Repeat 3-5 times, and marvel at your new looking contact.

http://i290.photobucket.com/albums/l...E/IMG_2161.jpg


Now, before you reasemble the box, make sure your FET has enough remaining thermal grease to dissapate heat properly... In my case, I wiped it away and used thermally conductive gap pad.

Add thermal grease if you need to.

http://i290.photobucket.com/albums/l...E/IMG_2162.jpg

http://i290.photobucket.com/albums/l...E/IMG_2163.jpg

http://i290.photobucket.com/albums/l...E/IMG_2164.jpg


Now reattach the PCB the reverse of removal.

Using standard RTV, run a bead around the edge and screw the cover back on.

http://i290.photobucket.com/albums/l...E/IMG_2165.jpg


Bolt up the box to its bracket and run the cable along the same path you took it out of. BE SURE TO RUN THE CABLE INTO THE GROOVE BEHIND THE BATTERY TRAY, SO THAT WHEN YOU PUT THE TRAY BACK IN YOU DO NOT SMASH THE CABLE.

Hook up the cable end to the lever post by rotating the lever towards you and sliding the groove of the cable end on to the post.

Replace airbox/upper half CAI/SRI, battery tray, and battery.

Hook up battery... Start car... and enjoy your engine codeless dash [wiggle]

I'm sure I forgot something, I will edit as I remember things or get suggestions from other members.

SVTRSST 01-26-2010 11:33 PM

very nice! thats what i was thinking how can this stupid system fail?!, i need to remove the little chip though..

any kind of grease we should use with the gears?, can the motor ever fail?

LongDucDong 01-27-2010 09:56 AM

Nice write-up!

macdiesel 01-27-2010 12:20 PM

I remember the original write up. I thought the guy cleaned/lubed the gears up too. Nice write up.

SquirrelZX3 01-27-2010 01:37 PM

nice write up but so far my svt seems to be operating just fine but good to know if i have any future problems

RyersonUnit 01-27-2010 05:34 PM

Thank you so much!! This answered all my questions! Woot...saves me like $500CDn

Adam

WD40 01-27-2010 05:39 PM

Quote:

Originally Posted by SVT_ME (Post 3124029)
First off, credit for this idea goes to an older thread which now seems to be gone.

[scratch]
It's right there in the "New Members Read Here First. SVT Performance Chat "Read First" Threads."
(in the "SVT Specific: How To and Information Links")
"How To" Intake Manifold Runner Control disassembly"NEW"

Regardless, thanks for the more in depth write up. [thumb]

SVT_ME 01-28-2010 12:54 PM

Quote:

Originally Posted by WD40 (Post 3125706)
[scratch]
It's right there in the "New Members Read Here First. SVT Performance Chat "Read First" Threads."
(in the "SVT Specific: How To and Information Links")
"How To" Intake Manifold Runner Control disassembly"NEW"

Regardless, thanks for the more in depth write up. [thumb]


Thanks for the heads up WD [cheers]

Odd, I clicked the original link and it didn't work...

Anyway, now there are 2.

SVTROADRACER 01-31-2010 06:18 PM

Nice write up!! My only question is, do i still need to remove my battery with it being in the trunk? J/K!![poke]

tczx3 01-31-2010 06:32 PM

As a side note to possible failures... If you have the 'marbles in a coffee can rattle' at start up the problem is the plastic pulley that the cable attached to inside the IMRC. See pic #9. The shaft that turns the pulley can strip the engagement pin on the pulley. If you open up your IMRC and have plastic shavings the pulley is toast and unrepairable. In my case this failure was caused by a faulty DSI manifold. The runner that rotates inside the manifold was beginning to 'sag' from the pivot points wearing and the runner was catching/binding causing the pulley in the IMRC to fail. I suspect the runners catching and binding is the actual cause of the broken DSI clip that so many experience.


All times are GMT -5. The time now is 05:21 PM.