Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   Drag Racing (http://www.focusfanatics.com/forum/forumdisplay.php?f=96)
-   -   what was my problem at the drag strip? (http://www.focusfanatics.com/forum/showthread.php?t=194532)

SVTRSST 04-04-2009 05:06 PM

what was my problem at the drag strip?
 
hey, yesterday i went for first time to my local dragway, and it was BAD

the damn place was full of hondas, most of them between the 14.9-16 sec range, i felt like i wanted to kill some, but it wasnt like that, the first time i ran it was alone. I didnt burn the tires, but the floor had some water. i Rev to 4000 rpm, launch droping the clutch, and damn it seems like the car got loose on tires, it grabs again, i shift to second, then WTF, something happened and the car didnt pull... i was all scared, i thought i F'ed the engine or something.. then i remembered a guy from local that F'ed his tranny at the drag tree...I almost cried.. then i let off the gas pedal and press it again, suddently my torque comes back but it was too late.. i ran 23 sec 1/4 mile how you like that???''


i went for another race, i thought maybe it was the rev limiter, didnt spin tires again, reved to 2500 rpm, dumped clutch, and yes the car went out ok, shifted to second everything was fine, third, fine, finally i was happy, after like 2 seconds of third gear, it happens again!!.. didnt pull.. i made a bad 18 sec run this time.. i was scared again, parked somewhere and opened the hood to see if something was out of place, nothing bad, i looked under the engine.. no leaks or anything, i went with my friends to ask them if they saw something.. they said no, i was like uhm.. i called a friend to ask him what could it be, he said maybe some shit on gasoline that was on 1 inyector or something.

i didnt race again, i was thinking it could be something worst than that.

when we left ( we had to drive some highway), the car felt ok like always,.. i remembered of a road that nobody uses, and its in very good condition, so i decided to run from stop to 3rd gear (about 90miles, which is what svts run at 1/4), i did it with 3 of us in the car, and wot it did run good, pretty good actually.. one of my friends ( he went with me the first race) said that the car felt really different than at the dragway.. do you think it could have been the shit on some inyector or what ?

i can also say that back home i was driving at high rpms and the car sounded and pulled ok..

Buickboy 04-07-2009 04:30 PM

dont drop the clutch, feather it out

PumkinSvt 04-07-2009 04:37 PM

Yea feather the clutch dont dump it!

also whats inyector??

SVTRSST 04-07-2009 04:51 PM

i meant injector.. well the problem was not dumping the clutch or not, so anyone?

streetracer 04-08-2009 09:54 AM

did it sputter when you were flooring it in 3rd?

Motor_head 04-08-2009 10:23 AM

How old is your clutch? Sounds to me like you were spinning the clutch, got it hot, and then it spun on you in third.

SVTRSST 04-08-2009 02:34 PM

sorry whats sputter?, my clutch has less than a year and its a stage 2 clutch

uncle tail 04-09-2009 12:33 PM

drop your launch revs

thenorm 04-09-2009 01:17 PM

turn off your Traction control. its the little button near the Ebrake handle, the icon kinda looks like a tire. when u have turned it off the TC light should stay on, in ur dasg

the traction control is what stole all you power when u spun tires briefly. unfortunatly its wait a second or two to give it back.

remember that you have to turn it off each time you start the car cuz it resets. You also can pull a fuse (but this disables ABS too). but i cant remember which one. a search would tell.

focusmaniaczx3 04-11-2009 06:18 AM

bwaaa i hate traction control. worthless junk. test drove a magnum srt-8 last year with that junk and it sucked. it was scary fast from a roll but the SOB wouldnt spin a tire to save my life.


All times are GMT -5. The time now is 07:35 PM.


http://www.focusfanatics.com/aboutus/copyright.asp