Focus Fanatics

Focus Fanatics (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   Just had timing belt and water pump changed now car is overheating?!?!? (http://www.focusfanatics.com/forum/showthread.php?t=178841)

DanielW 11-10-2008 12:46 PM

Just had timing belt and water pump changed now car is overheating?!?!?
 
ok so I just had some maintenance done on my car like 50 miles ago. I had the water pump, timing belt, tensioner, fuel pump, and brakes all changed. When I left the mechanics shop I noticed the car was running much better but there was a slight whine coming from the engine that would increase in pitch the faster I went. eventually it seemed to go away and the car was running great until about an hour ago. I pulled into school and right as i pulled into the parking deck i smelled the smell of a car overheating. I looked around to see who it was but as i continued through the deck the smell followed. I the pulled into a parking spot and saw the dreaded steam rising from the hood of the car. So its deffinitely overheating. What could be the problem? I bought the water pump from partstrain.com and when it came it said it was remanufactured. could it be bad? or is there something the mechanic could've screwed up? Please help!!! this is my daily driver and i need her running

the Duff 11-10-2008 01:42 PM

Take it back to the mechanic. That should be a no brainer. The sad part is it sounds like you supplied your own parts, so if your water pump was bad out of the box you'll probably have to pay for the labor for them to replace it. I'm a mechanic at a Ford dealer and we warranty parts and labor for 12 months 12,000 miles, unless that is, the customer supplied there own parts. Likely not your water pump though. I bet someone forgot to tighten a clamp. Whining noise could possibly be overtightened timing belt. Couldn't tell you without looking at it though.

DanielW 11-10-2008 01:57 PM

yeah I'm already taking it back to the mechanic. when you say clamp... do you mean like a hose clamp? is there anything in particular i can look for myself?

Mr.Bergner 11-10-2008 02:24 PM

Have you considered looking into the thermostat? Here's some info on it: http://www.focushacks.com/index.php?modid=59

DanielW 11-10-2008 08:39 PM

hey guys thanks for all the input. It looks like the car wasn't actually overheating. The valve cover gasket went and it was leaking oil onto the engine and it was burning off making me think i was overheating. anyway got that part replaced and everything is all better now.

viney266 11-10-2008 09:37 PM

Glad its fixxed


All times are GMT -5. The time now is 10:50 PM.


http://www.focusfanatics.com/aboutus/copyright.asp