Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum

Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum (http://www.focusfanatics.com/forum/index.php)
-   General Technical Chat (http://www.focusfanatics.com/forum/forumdisplay.php?f=47)
-   -   Thermostat housing, How-to, but need detail. (http://www.focusfanatics.com/forum/showthread.php?t=174420)

Executionerhk 09-27-2008 11:42 AM

Thermostat housing, How-to, but need detail.
 
My car is still overheating after changing the themostat housing... what is going on...
and one can help again?

Guys,

I think my Thermostat housing is leaking... and I have a graph here. I know I should be able to do it... Still I want to have some more detail from guys who did it already...

Plus, this graph is going to help the rest of people who need help with the Thermostat housing. See bottom!

Thanks
Steven


http://x5a.xanga.com/630856f21571821...w166348341.jpg

Executionerhk 09-27-2008 11:48 AM

i got a deal from the dealership as well...
8592 ASY with O-ring to the block from $58.76 to $41.13
the O-ring for the thermostat W700319 S300 from $8.00 to $5.60

Now I only need some experience talk and I will get my hand dirty...
Just want to know detail steps and what difficulity I might have and so on...

Thanks guys...
and hope you can sticky the graph... i think it is not on the How-to anywhere.

..:: sleestak ::.. 09-27-2008 12:24 PM

  • Park car and get her on jack stands
  • Put drain pain under radiator and drain that sucker via drain plug on bottom drivers side
  • Disconnect hose that attaches to the front of housing.
  • I believe there is a sensor there too..disconnect wire to sensor. Be careful though, the heat can make that plastic brittle
  • Unbolt housing from block via 3 bolts on side of housing
  • Remove housing
  • Take front piece off the housing to remove the thermostat. **Take note of the little hole on the front/top of thermostat. When you put it back in, this hole should be on the top
  • Remove tiny clips from silver plugs in housing and swap them into the new housing. You may have to replace the o-rings, mine got perma-sealed to the housing from heat and chemicals and needed to be replaced.
  • Remove clip and sensor from housing and swap to new housing...again, be careful. Heat can make plastic brittle.
  • Put thermostat in new housing (with hole facing u)
  • Put new oring in place
  • Bolt housing to block
  • Re attach hose to front of housing
  • fill up car with new coolant/water
  • FIN!!




Extras I might recommend, o-rings for the silver plugs in housing and possibly a new sensor. You might want to take this opportunity to switch to the lower temp Thermostat, if your mods dictate.



hope this helps

..:: sleestak ::.. 09-27-2008 12:30 PM

One more thing....the most common cause for a leaky thermostat housing is a leaky valve cover gasket!

The oil will seep out and down the side of the block. It gets in between the block and the housing and hits the rubber O-ring, causing it to swell. Then the swelling causes the plastic area around the O-ring to crack and cause a leak.

Not saying you have to do this as well, but it would be a good idea to look for evidence of this happening. Keep it wiped down and if you think this is your cause, think about replacing the valve cover gasket....its fairly cheap and easy to do.

Executionerhk 09-27-2008 04:01 PM

i have the valve cover gasket in three months ago...
now i have already replace the housing...
the housing itself was not crack... but shady... so i got new one in...
new thermostat and ring...
coolant flush and new coolant!!
all ready to go...!!

Executionerhk 09-27-2008 11:42 PM

guys i still got heating problem...
guys please help...

SpeedOften 09-28-2008 08:43 AM

check your thermostat - it may need to be replaced.

iminhell 09-28-2008 03:22 PM

Well, do the fans come on?
If not there is your problem, with the solution probably being a new Cooling Fan Resistor Pack.


btw, I edited the 56K off the title because with only 1 picture I didn't see it as being needed.

Executionerhk 09-28-2008 10:07 PM

Today... I drain the coolant again...
because I have 100% coolant in it...
before I put water, i drove for like 20min hard no problem...
but when i turn the A/C on... it starts heating up
so I put 50% water in there... and us 50/50 coolant...
let the car run and crank the heat up to fill the coolant up...
15mins later, drove it really hard with A/C on max...
and it still over heat...

SpeedOften, my themostat is brand new... but i will go ahead and check it...
should I get the advance auto parts one or Ford one?
Iminhell, my fans are both working... thanks for chaning the 56k... because it is like 3mb..

btw... i am so stupid to twist the radiator drain cap to broke off...
want can I do?where can I find another plug, or can I even find another plug?

Executionerhk 09-29-2008 10:43 AM

Morning bump...

just want you guys to follow up my question/problem i had last night!!


All times are GMT -5. The time now is 12:06 AM.