Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Tech Discussions > General Technical Chat > 2006 Focus ZX5 Manual trans - OD/Off light and engine light on

General Technical Chat This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: 2006 Focus ZX5 Manual trans - OD/Off light and engine light on Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-15-2014 03:57 PM
sailor http://www.focusfanatics.com/forum/s...ge+cluster+fix

Check this thread out, it may apply to your problem.

My past issues like this were "solved" when I switched to a different cluster with a tach. (upgrade I wanted anyways). This newer info. is worth checking out, haven't tried it on the old cluster yet as I just noticed this recently.

Luck
02-15-2014 11:33 AM
tjeens
2006 Focus ZX5 Manual trans - OD/Off light and engine light on

I have a manual transmission and recently (during cold temps of around -10 to -20 C) I started seeing the OD/Off light come on (which I thought was weird for a manual tranny. On warmer days (-2 to +10 degrees Celcius) the OD/Off light didn't come on. However, after 3 days, now I start seeing the engine light come on as well as the Od/Off light. The car drives fine (no slippage, no high revs - it drives as it should). The lights even stay lit after the key is out of the car. Just paranoid that the lights are a sign of something serious about to go wrong. Any ideas? Both lights are dimmly lit as opposed to the rest of the lights on the dash - not sure if that is a clue or not. Most postings on the web all revolve around automatic transmissions and the button by the gear shift lever which mine of course doesn't have. Thanks in advance.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:15 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.