Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus SVT > SVT Performance (2002-2004) > Power steering problem on an 04?

SVT Performance (2002-2004) The place to chat about any 2.0L SVT DOHC Zetec engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Power steering problem on an 04? Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
11-27-2005 11:02 PM
pspringe I lost my ps at low RPMs. The dealer replaced it, they told me I cooked the seal in it (on the Dragon's Tail).
11-19-2005 12:58 PM
JohnMichael I just noticed the same thing this morning...my PS fluid is low. I also have a slight leak from my Thermo sensor housing, that I just found out is Coolant. I am about to replace the bad o-ring and see what happens.
09-17-2005 12:10 PM
sbsvt02 I've had to work on an 04 svt when it came in. It had the same leak you are descibing. Its the ps pump shaft seal that runs out of the pully. Replace the pump and it will be fixed.
09-11-2005 03:59 PM
Toolman00 Ok guys, resurrecting one from the past. I got my oil changed yesterday and the guy changing it noticed that there was a slight leak from the power steering pump. My fluid read slightly over the MIN COLD mark after a nice drive.

I haven't noticed any puddles, but obviously something is leaking as my belt has fluid on it and there is an oily mess around the pump.

Any recalls or TSB's on this?
04-19-2005 07:15 PM
QuickSilverSVT mine clicks sometime when i cut the wheel
04-19-2005 06:41 PM
Daeron pump acting up most likely
04-19-2005 06:38 PM
Toolman00
Power steering problem on an 04?

Well, this morning when driving my SVT I didn't have power steering. Checked under the hood when I got to work, no leaks or puddles to be found (thank God!), full tank of PS fluid (actually it's a tad too much - from the factory). Took it home tonight and the power steering is back...

Anybody have any clue what happened?

I took the last corner to work pretty fast, pulled into the lot and noticed the steering was a beotch. No loud squeaks or anything commonly associated with PS problems.

I probably should have had the dealer check it out, but it's running fine now...

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:23 PM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Audi S3, Ford Fusion and Acura TLX. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. Challenger Hellcat - Charger Hellcat