Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum > Ford Focus First Generation > SPI Performance (2000-2004) > Poll: Has your SPI dropped a valve seat?

SPI Performance (2000-2004) The place to chat about any 2.0L Split Port Injection engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
FocusFest FocusFanatics Merchandise

Thread: Poll: Has your SPI dropped a valve seat? Reply to Thread
Title:
  
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum, Ford Focus RS Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
What I Drive
Year, color, and model of your car. Example: 2003 Pitch Black ZX3
Name
Your real name.
City
State
Country
Insurance
Please select your insurance company (Optional)

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
04-20-2016 04:15 PM
elkocaballero 2001 286,XXX Kms hasn't dropped. Yet.
04-17-2016 11:18 PM
ratedterror 240k original spi engine. Car has never had any major work done to it, but I am worried because I was washing the car the other day, and steam was coming off the hood from the water. But my temp gauge was normal readings, any thoughts?
02-23-2016 12:24 AM
amc49 You have no idea. However, just by the numbers alone some of them HAVE to make the full distance. Whatever you do, don't overheat it.............
02-21-2016 06:59 AM
PorkchopSanwich My 2002 SE is currently sitting at 202,000 and has not dropped one yet, still original motor and transmission, I guess I'm just lucky!
02-03-2016 09:26 PM
Westwood13 2000 focus se 230,000 miles. Fourth engine. Fist motor dropped #1, 2nd and 3rd dropped #4.
11-25-2015 09:52 PM
amc49 Can't drive these without the fans working............you CAN but just like all the others who overheat over and over thinking they'll fix it when the next check comes in you'll end up in the scrap pile.

The fan motors themselves rarely fail, it is the cooling electrical circuit on top that controls them that fails left and right.

I myself strongly suspect that some of the aftermarket head suppliers do nothing to the heads at all other than fix them, nothing done for that dropping issue at all. Just lip service.
11-25-2015 03:22 PM
sailor Look/post in General Tech Chat for more help with the fans, the fans themselves are SELDOM a failure point.

Lack of low speed fan operation is a common issue, and the resistor/connector to it is only one of the possible causes.

Sorry to hear you have to deal with this again, overheating on those can cause head gasket troubles as well so you may have dodged one bullet only to be hit by another.
11-25-2015 02:19 PM
WhyDidIBuyaSPI
2nd head dropped a valve! :(

Bought a cheap 2004 Focus LX for my kids to drive.

I started reading your Forums and asked several colleagues including mechanics about the SPI head failure and everyone said they never heard of it. Three months later, my engined failed because of the dropped valve guide. I bought a reman head from justheads. One year later, same thing.

Both times it failed on a hot day. I realized that the cooling fans don't work. I have to order another one. This time I will get a new aftermarket casting. I will also need to fix the fans. The resistor looks ok. I think I will buy an aftermarket fan to replace it.
11-02-2015 05:09 PM
Fuelish1 Can't say if mine has or hasn't, bought it used about a year ago, third-hand....no records from original owner and spotty receipts from second owner... '03 with about 148,000 miles on it atm...I'll be pi$$ed if it does happen, as other than that, car is great for what it is
10-31-2015 01:34 PM
beneboo dropped right before 143K miles
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 01:10 PM.


Copyright 2002-2015 FocusFanatics.com. All Rights Reserved : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Mazda CX-3, Audi S3, Mazda MX-5 Miata and Acura TLX. You can find all Ford Focus, Focus ST and Focus RS related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area. If you own other makes have a look at Challenger Hellcat Forum, Charger Hellcat Forum, Cadillac ATS-V Forum, Cadillac ATS Forum, Cadillac CTS-V Forum, Lexus RC-F Forum, Lexus GS-F Forum, Mercedes GLA Forum, Mercedes GLE Forum, Civic Type-R Forum and Volvo XC90 Forum.




 

Search Engine Optimization by vBSEO 3.6.1