Ford Focus Forum, Ford Focus ST Forum - Reply to Topic
Ford Focus Forum
HomeContact UsAbout UsGalleryDiscussion ForumsMarketplace


Go Back   Ford Focus Forum, Ford Focus ST Forum > Ford Focus Third Generation > DURATEC Ti-VCT Performance (2012-Current) > Tuning Solution (Injected Engineering)

DURATEC Ti-VCT Performance (2012-Current) The place to chat about any Duratec 2.0L Ti-VCT engine performance, tuning and exhaust related upgrades.

Search This Forum | Image Search | Advanced Search    
Ford Focus Tire & Wheels FocusFanatics Merchandise

Thread: Tuning Solution (Injected Engineering) Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the Ford Focus Forum, Ford Focus ST Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Additional Options
Miscellaneous Options

Topic Review (Newest First)
09-14-2014 02:58 PM
Juicedz Yea, being able to chirp second is a great feeling coming from a car that looks this good, while getting 35-40mpg on the freeway.
09-10-2014 05:43 PM
cbtrac Thanks
09-05-2014 10:33 PM
RedDen
Quote:
Originally Posted by cbtrac View Post
Just received my blank device in the mail, followed all the instructions and sent my first email. Can't wait!
Congrats, keep us updates how this works out for you.
09-05-2014 06:42 PM
cbtrac Just received my blank device in the mail, followed all the instructions and sent my first email. Can't wait!
08-29-2014 11:10 AM
VisionPilot
Quote:
Originally Posted by darkangelism View Post
I get 2500 rpms, but that is what people get without the tune, except you.
Maybe the difference is that mine is a 14 and yours is a 12, along with the fact that I have the Aug'14 TSB installed? Can't believe I have the only focus with brake pedal override on the accelerator.
08-29-2014 11:00 AM
darkangelism I get 2500 rpms, but that is what people get without the tune, except you.
08-29-2014 07:43 AM
VisionPilot
Quote:
Originally Posted by gwun88 View Post
Not sure if this has been mentioned but the tranny has to be in sport mode with the traction control turned off.
I've never seen that mentioned before, will try it, thank you!!!!

Well, no go on "launch control" no difference.... rpm's go to 1250, then back down to 1000 or under.....
08-29-2014 07:31 AM
gwun88 Not sure if this has been mentioned but the tranny has to be in sport mode with the traction control turned off.
08-29-2014 12:05 AM
novus
Quote:
Originally Posted by sailor View Post
Check out this thread on "Drag" launch with the DCT:http://www.focusfanatics.com/forum/showthread.php?t=384018

Foot on brake and accelerator it'll rev. to 2,500 & take off when you lift your foot off the brake.
This ain't no GTR.
They ain't going to help replace the DCT if something goes wrong by doing this lol
08-28-2014 02:05 PM
VisionPilot
Quote:
Originally Posted by sailor View Post
Check out this thread on "Drag" launch with the DCT:http://www.focusfanatics.com/forum/showthread.php?t=384018

Foot on brake and accelerator it'll rev. to 2,500 & take off when you lift your foot off the brake.
Mine does not allow the rpms to climb with the brake applied. I have tried, just to see how much slip I could get. It goes momentarily above 1100, then backs back down to 750rpm idle, no matter how much gas you give it. I think it's Ford's answer to Toyota's dilemma with the stuck accelerator and those drivers trying to brake to no avail. Mine obviously has a throttle cutout when the brakes are applied.

That's what I was hoping the DCT reprogram from IE would solve, but apparently it doesn't.
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 04:40 AM.


Copyright 2002-2014 FocusFanatics.com. All Rights Reserved : Terms of Use : Privacy Policy : Advertise Information

Focus Fanatics Ford Focus Forum offers many fun ways for you to engage with other Ford Focus Owners from across the world. Whether it be about the aftermarket performance modifications, technical how-to's, European tuned suspension or awesome fuel economy similar to the Acura TLX or Fiesta ST. You can find all Ford Focus and Focus ST related information here. Join our Ford Focus discussion forums and chat with local Focus enthusiasts in your area.